Download it now!
Bug 43533 - FILESAVE: line position get lost
Summary: FILESAVE: line position get lost
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-05 05:46 UTC by wawersich
Modified: 2015-04-25 15:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
zip file containing an odg-document and some pictures (203.19 KB, application/x-zip-compressed)
2011-12-05 05:46 UTC, wawersich
Details
drawing that demonstrates strange UI behaviour (9.00 KB, application/vnd.oasis.opendocument.graphics)
2012-01-09 02:53 UTC, sasha.libreoffice
Details
Testcase using Right Angle Connectors in 4.1.0.4 (167.51 KB, application/zip)
2013-08-08 14:48 UTC, Sean
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wawersich 2011-12-05 05:46:29 UTC
Created attachment 54121 [details]
zip file containing an odg-document and some pictures

Problem description:


Steps to reproduce:
1. open the file bug.odg
   it should look like screen1.png
2. click on the red line (like screen2.png) and move the middle point to the left text. It should now look like screen3.png.
3. Save the file and close it.
4. re open the file and it looks like screen1.png - but it should look like screen3.png.
Current behavior:

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 Jean-Baptiste Faure 2011-12-05 21:48:10 UTC
I reproduce the problem with LibO 3.4.4 FR under Ubuntu 10.04 x86_64
It seems that master has the same behavior (build ID : f4b3bd9-43e9388-090bcba-3bf3b94-05891e7).

Best regards. JBF
Comment 2 sasha.libreoffice 2012-01-09 02:53:55 UTC
Created attachment 55325 [details]
drawing that demonstrates strange UI behaviour

My be this bug is related to original report
Steps to reproduce:
0. Open my attachment
1. Select curve 
2. Slightly move square red handle
Expected: curve slightly changes
Actually: curve jumps to become almost direct line immediately
Comment 3 Sean 2013-08-08 14:48:02 UTC
Created attachment 83841 [details]
Testcase using Right Angle Connectors in 4.1.0.4

Open line_format_save_test.odg and it will look like after.png.  Move the lines to look like before.png.  Save the file.  Close & reopen the file.  It will look like before.png again.
Comment 4 Sean 2013-08-08 14:50:41 UTC
I've reproduced this same behavior in Fedora 19 using Version: 4.1.0.4
Build ID: 4.1.0.4-5.fc19.

However, I found mine with "normal" right angle connectors.  This is a very irritating bug as it starts to make Draw much less useful as it cannot properly save even slightly complex diagrams.

See my attachment "Testcase using Right Angle Connectors in 4.1.0.4" and execute the testcase by:

- Open line_format_save_test.odg
- It should look like after.png
- Modify the diagram to look like before.png
- Save the file.
- Close and reopen the file
- It will now look like after.png

Thanks.
Sean
Comment 5 ign_christian 2013-09-07 03:08:08 UTC
Hi Sean, looks like your problem has different root cause. Because I still can reproduce problem with OP's (wawersich) file, BUT I can't reproduce problem with your file.

Your problem looks like Bug 68104, this bug looks like Bug 52245 (with different behavior)

Tested on LO 3.6.7.2 (Ubuntu 12.04 32bit)
Comment 6 Sean 2013-09-07 22:49:45 UTC
Thanks for the reply ign_christian. I see that Sasha & the OP had problems with 3.x and you're running 3.x.

I also see that Sasha, and myself, (and perhaps the OP) are on x64 and you are on 32-bit.  Perhaps this is part of the problem?

Sean
Comment 7 Erdal Mutlu 2013-09-10 05:57:11 UTC
Yes I have tested with arch linux (64bit) 4.1.1.2 and the attached file. This bug is related to https://bugs.freedesktop.org/show_bug.cgi?id=68104
Comment 8 ign_christian 2013-10-10 14:29:45 UTC
> I also see that Sasha, and myself, (and perhaps the OP) are on x64 and you
> are on 32-bit.  Perhaps this is part of the problem?

I don't know Sean.. But I think because Sasha & OP ran old version of 3.x, but I have newest 3.x (3.6.7) :-)

Perhaps you could also test with 3.6.7 to see whether your problem solved (not OP's).
Comment 9 Sean 2013-10-10 17:09:57 UTC
I've been running a test on my Fedora 19 x64 machine every time there is a stable update (of LibreOffice Draw) pushed to the repos and so far the problem is always there.  The last test I ran was against 4.1.2.3-2

Sean
Comment 10 Sean 2013-10-11 12:17:58 UTC
Just updated again... still broken on Fedora 19 x64 LibreOffice v4.1.2.3-3

Sean
Comment 11 QA Administrators 2015-04-19 03:22:11 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 12 Jean-Baptiste Faure 2015-04-25 15:44:01 UTC
Not reproducible anymore with LibreOffice 5.0.0.0.alpha1+ built at home under Ubuntu 14.10 x86-64.
Not reproducible with LibreOffice 4.4.4.0.0+ built at home under Ubuntu 14.10 x86-64.

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF