Bug Hunting Session
Bug 43777 - Database list box display on MacOS X: new value superimposed on old value instead of replacing old value
Summary: Database list box display on MacOS X: new value superimposed on old value ins...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: Other Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Button-Controls
  Show dependency treegraph
 
Reported: 2011-12-12 19:34 UTC by George Creegan
Modified: 2019-11-02 15:41 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
New Database.odb (1.43 MB, application/vnd.oasis.opendocument.database)
2012-06-12 08:21 UTC, George Creegan
Details
screenshot2.tiff (13.48 KB, image/tiff)
2012-06-13 12:10 UTC, George Creegan
Details
screenshot.tiff (12.06 KB, image/tiff)
2012-06-13 12:10 UTC, George Creegan
Details
Base Combo Box MacOS screen refresh problem (10.62 KB, image/png)
2013-12-05 05:22 UTC, frofa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description George Creegan 2011-12-12 19:34:58 UTC
list box contents continually overwrite as new selections from the list are made.  After a few changes in contents the value displayed is no longer legible.
Comment 1 Thomas Hackert 2012-01-22 07:06:27 UTC
Hello George, *,
would you be so kind to explain it a little bit more? Could you elaborate it with a step by step instruction and maybe an example document and/or screenshots, please?
Sorry for the inconvenience
Thomas.
Comment 2 George Creegan 2012-01-27 14:38:09 UTC
Thomas,

Thanks for your response.  I'm including an attachment which  
illustrates the problem.  "New Database.odb".

If you open the file "New Database" and select "Forms" on the left  
side of the screen, and right click on the "Customer Screen" form to  
open it.  You will see a simple form I set up for this example.  In  
the center top of the form you should see a combo-box next to the word  
"Tier".  If you select an item from the list it will appear in the  
blank box above the list.  If you then select another item from the  
list it will be written over the first entry in the box.  In other  
words, BOTH entries show up on top of each other and therefore the  
entry becomes unintelligible.
I originally created this file in NeoOffice if that helps you in  
discovering the solution.  Can you let me know when/if you receive  
this email and the attachment?

Thanks, and good luck.
George




----------------------------


On Jan 22, 2012, at 9:06 AM, bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=43777
>
> thackert@nexgo.de changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |NEEDINFO
>     Ever Confirmed|0                           |1
>
> --- Comment #1 from thackert@nexgo.de 2012-01-22 07:06:27 PST ---
> Hello George, *,
> would you be so kind to explain it a little bit more? Could you  
> elaborate it
> with a step by step instruction and maybe an example document and/or
> screenshots, please?
> Sorry for the inconvenience
> Thomas.
>
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi? 
> tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 3 Robert Großkopf 2012-06-07 11:21:39 UTC
Created attachment 62935 [details]
New Database.odb

There is no attachment "New Database.odb".
Reading your description I think its the normal bahaviour of a combobox: changing the entry must overwrite the field.
Could you please add an attachment, which shows the behaviour and what should be wrong?

Robert
Comment 4 George Creegan 2012-06-12 08:21:10 UTC
Robert,
Thanks for the response.
I'm attaching the file: "New Database.odb" which shows the problem.   
Open the file and select the Customer screen in the Forms section.   
Then, in the form, select a Tier from the dropdown list.  You'll  
notice that the number writes ON TOP OF the previous entry.  I checked  
the Sent Box in my email and I DID attach the file to my initial  
message.  Don't know why you didn't get it!!
Here it is again..
Thanks,
George
Comment 5 Robert Großkopf 2012-06-13 02:48:06 UTC
Created attachment 62982 [details]
screenshot2.tiff

Hello George,

I opened the attached "New Database.odb".
First: There is no list box, but a combo-box. In a combobox you can enter new values.
Second: Could be I do not understand what you mean: I change the item with the mouse. The changed value appears in the box. Go forward and back to the same row. The changed value has been saved to the table. Chould change it very often - there is only the one item I had choosen in the box above. This is the normal behaviour of a combo-box.
I have tested it under Linux-rpm32 with LO 3.3.4 and LO 3.5.4, not under Mac with 3.4.4 as you reported the bug.

A little hint for crating attachments. Your "New Database.odb" has about 1.43 MB. When I rund at Extras → SQL the command "SHUTDOWN COMPACT" it has 13.2 KB. Thee ara much data inside which are not used.

Robert
Comment 6 George Creegan 2012-06-13 12:10:23 UTC
Robert,
Thanks again for your quick response.  Sorry, I mis-characterized the  
combo-box.

Just to be clear - if you select a number from the drop down list  
under the title "tier" that number will appear in the field above.   
But if you then select another from the list it will not replace the  
first number but will be written on top of the first number.  I will  
send you two screenshots of the result after selecting several numbers  
from the list.  Notice "screenshot2" which is a ZOOMED version of the  
first.  It appears that there are several overlapping boxes!  Maybe  
this has something to do with my problem!

  But from your results, it seems my problem MUST be with LO version  
3.4.4 when used on a Mac OSX 10.5.8.
If you ever have a chance to test my version of LO with a Mac using  
the database I sent you, I bet the problem will show up!
Also, to be honest, I have no idea why the .odb file is so large.  As  
you can see there is not much data in it!
Here's the screenshots:
Thanks for any additional help you can provide.
George
Comment 7 George Creegan 2012-06-13 12:10:24 UTC
Created attachment 62983 [details]
screenshot.tiff
Comment 8 Robert Großkopf 2012-06-14 07:17:50 UTC
I see your problem. Seems to be a problem of LibO 3.4.4 with Mac. Isn't there a newer version of LibO for Mac?
I have switched the status to new.
Again for the big *.odb-file: HSQLDB saves old content in the database. Could be you have deleted much rows but the file is bigger than before.
You have only to run the command "SHUTDWN COMPACT" in the SQL-mode. The old data, which you can not see, would be deleted.

Robert
Comment 9 George Creegan 2012-06-14 09:04:24 UTC
Robert,

I'm glad you were able to see the problem.

Regarding the BIG .odb file - you are right!  It started as a large  
file that I deleted columns and rows from.  I never expected that the  
data deleted or the space allocated would still be in the file!   
Thanks for the info.  I will use the command you suggested to clean it  
up.

Sincerely,
George

----------------------------------------


On Jun 14, 2012, at 9:17 AM, bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=43777
>
> robert@familiegrosskopf.de changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|NEEDINFO                    |NEW
>
> --- Comment #8 from robert@familiegrosskopf.de 2012-06-14 07:17:50  
> PDT ---
> I see your problem. Seems to be a problem of LibO 3.4.4 with Mac.  
> Isn't there a
> newer version of LibO for Mac?
> I have switched the status to new.
> Again for the big *.odb-file: HSQLDB saves old content in the  
> database. Could
> be you have deleted much rows but the file is bigger than before.
> You have only to run the command "SHUTDWN COMPACT" in the SQL-mode.  
> The old
> data, which you can not see, would be deleted.
>
> Robert
>
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi? 
> tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 10 Alex Thurgood 2012-07-02 00:57:05 UTC
Hi Geroge,

I will test this later on my Mac, but you should try updating to a newer version and see if your problem still persists, and report back here. There were are few known visual defects in the 3.4 series, maybe this was an extra one that went unnoticed for a while. It would be good to have a test on one of the latest versions of LO.


Alex
Comment 11 Alex Thurgood 2012-07-02 00:57:55 UTC
(In reply to comment #10)
> Hi Geroge,

Sigh, sorry George, mistyped your name


Alex
Comment 12 George Creegan 2012-07-12 23:11:51 UTC
Alex,
I took your suggestion and downloaded & installed LibreOffice 3.5 for  
the Mac and I have the same problem with the combo box.  Just FYI.
George

------------------------


On Jul 2, 2012, at 2:57 AM, bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=43777
>
> --- Comment #10 from Alex Thurgood <iplaw67@yahoo.co.uk> 2012-07-02  
> 00:57:05 PDT ---
> Hi Geroge,
>
> I will test this later on my Mac, but you should try updating to a  
> newer
> version and see if your problem still persists, and report back  
> here. There
> were are few known visual defects in the 3.4 series, maybe this was  
> an extra
> one that went unnoticed for a while. It would be good to have a test  
> on one of
> the latest versions of LO.
>
>
> Alex
>
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi? 
> tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 13 Lionel Elie Mamane 2013-12-02 11:52:29 UTC
(In reply to comment #10)
> I will test this later on my Mac,

@alex: could you please come back to this and try on your mac? It would be nice to have independent confirmation of this. Also with 4.0/4.1 since they came out by now. If this bug is still present, we should farm it out to a MacOS expert.
Comment 14 Alex Thurgood 2013-12-02 15:29:11 UTC
Confirming on master 4.3
Version: 4.3.0.0.alpha0+
Build ID: 963fb6a84f1366028b185519144ce18e61d630c0


Alex
Comment 15 Alex Thurgood 2013-12-02 15:39:48 UTC
Bug also present in Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
Comment 16 Alex Thurgood 2013-12-02 15:54:04 UTC
Note that even without trying to click on values from the list, the control itself looks weird on the form. In Design view, the uppermost part of the control is shown as having a coloured background which is the same as the form background colour. However, in Data entry mode, i.e. in normal use mode, that same uppermost part of the control is shown half white/ half-coloured, with a clear horizontal separation of colour across this upper part (where data can in theory be entered manually).

I tested with different fonts on OSX in case it might have been a font problem, but my testing showed no difference in the results.

Alex
Comment 17 Lionel Elie Mamane 2013-12-02 15:59:52 UTC
Thorsten? You are our MacOS X "FindTheExpert" from the wiki. This is a MacOS-specific bug :)
Comment 18 Alex Thurgood 2013-12-02 16:04:09 UTC
Note that the problem does not exist in NeoOffice 3.4 patch 0 which displays the combo list values entered correctly.



Alex
Comment 19 Alex Thurgood 2013-12-02 16:06:40 UTC
The bug is also present in :

AOO400m3(Build:9702)  -  Rev. 1503704
2013-07-16 14:51:10 (Tue, 16 Jul 2013)

Alex
Comment 20 Alex Thurgood 2013-12-02 16:09:44 UTC
Tested also on :
LibreOffice 3.3.4 
OOO330m19 (Build:401)
tag libreoffice-3.3.4.1

where the bug also shows itself.

Setting version release to reflect that.


Alex
Comment 21 frofa 2013-12-05 05:19:01 UTC
Confirming this behaviour with Mac OSX 10.6.8 with LO Version 4.0.6.2 and also AOO 400m3. When I re-size the form window, a strange multiple overlapping pattern appears in the data-edit area at the top the combo box (see attachment). Looks like some sort of screen rendering bug. When the DROPDOWN control in the combo box properties is set to YES, there is no problem because the data-edit area is hidden.
Comment 22 frofa 2013-12-05 05:22:28 UTC
Created attachment 90288 [details]
Base Combo Box MacOS screen refresh problem
Comment 23 Alex Thurgood 2014-10-20 07:44:31 UTC
On 4322, OSX 10.10, one can see part of the main toolbar drawn in the background of the control (spellcheck buttons)
Comment 24 Alex Thurgood 2015-01-03 17:38:05 UTC Comment hidden (no-value)
Comment 25 QA Administrators 2017-01-03 19:54:53 UTC Comment hidden (obsolete)
Comment 26 eisa01 2017-11-05 16:10:16 UTC
This bug is still present

Version: 6.0.0.0.alpha1+
Build ID: 15dce20e8b97dbd0179f01910ca4d0027e80ff4e
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-10-20_06:46:46
Locale: en-US (en_US.UTF-8); Calc: group
Comment 27 QA Administrators 2019-09-29 03:07:42 UTC Comment hidden (obsolete)
Comment 28 eisa01 2019-11-02 15:41:17 UTC
This works for me now

Version: 6.4.0.0.alpha1+
Build ID: 80109586e6cb6d3e2e0a53a9079c3125ec9b8368
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded