Bug 43817 - mysql tinyint unsigned error
Summary: mysql tinyint unsigned error
Status: CLOSED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-14 03:37 UTC by Christian
Modified: 2011-12-14 04:37 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
error screenshot (5.64 KB, image/png)
2011-12-14 03:37 UTC, Christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2011-12-14 03:37:49 UTC
Created attachment 54417 [details]
error screenshot

hi,

when i connect base with mysql (native mysql extension),

http://extensions.services.openoffice.org/project/mysql_connector

I get an error after inserting a value > 127 to an unsigned tinyint field. (attached screenshot).

The error pops up after table refresh.
Comment 1 Alex Thurgood 2011-12-14 04:06:06 UTC
Hi,

AFAIK this behaviour is due to an old OOo bug in the underlying SQL parser code which I am unable to fix, it is not directly related to the connector as such.

If you try the same thing with an ODBC, you should notice the same error. I don't know whether the JDBC connector does the same thing (from my recollection, it does, but I'm not 100% certain about that).

So, not a bug in the connector, I think. You might want to open a bug report in general about not being able to set TINYINT UNSIGNED when using any mysql connection instead.

Alex
Comment 2 Alex Thurgood 2011-12-14 04:08:40 UTC
In order for the bug report to be made generally, you would need to test with other connection types : JDBC, ODBC.

If I get the time, I'll try and find the original OpenOffice.org bug that was referenced.


Alex
Comment 3 Alex Thurgood 2011-12-14 04:10:58 UTC
It would seem that this bug has resurfaced :


https://issues.apache.org/ooo/show_bug.cgi?id=18583

This was stated to be fixed in 2004, but apparently has come back to haunt us.


Alex
Comment 4 Alex Thurgood 2011-12-14 04:12:39 UTC
Closing. A separate report should be opened against the LO database component without reference to the connector, as this is only the vehicle by which the bug becomes apparent, and not the culprit (at least, so it seems).


Alex
Comment 5 Alex Thurgood 2011-12-14 04:17:05 UTC
See also, however, an underlying bug in the mysql engine code :

http://bugs.mysql.com/bug.php?id=18570

I have no idea whether this actually got fixed or not, so it may well be dependent on the version of mysql server that is being used.


Alex
Comment 6 Alex Thurgood 2011-12-14 04:20:57 UTC
Also see this old bug report (this was with an ODBC driver) :

https://issues.apache.org/ooo/show_bug.cgi?id=44333



Alex
Comment 7 Alex Thurgood 2011-12-14 04:37:10 UTC
http://bugs.mysql.com/bug.php?id=38171

and 


http://bugs.mysql.com/bug.php?id=50180

indicate to indicate that the bug actually lies with mysql's client libraries. These are used when building the connector, so it appears to be an upstream problem.

Setting to NOTOURBUG, unless other information provided to the contrary.

Alex