Download it now!
Bug 43832 - Artefact in vector on PDF Export
Summary: Artefact in vector on PDF Export
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-14 08:01 UTC by Rob
Modified: 2015-11-19 10:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Title bar from document that gets artefact in bottom-right corner on PDF export (9.75 KB, application/vnd.oasis.opendocument.text)
2011-12-14 08:01 UTC, Rob
Details
PDF result from LO 4.0.4.2 (17.99 KB, application/pdf)
2013-06-18 09:36 UTC, ign_christian
Details
PDF file with artifacts at corners in version 4.2.5.2 (19.29 KB, application/pdf)
2014-07-07 09:59 UTC, Johann
Details
Bug is still available in version 4.3.0.4 (15.00 KB, image/png)
2014-08-20 08:04 UTC, Johann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob 2011-12-14 08:01:46 UTC
Created attachment 54424 [details]
Title bar from document that gets artefact in bottom-right corner on PDF export

I put together a document using both Write and Draw with vector section separators (see attached file). When the file is exported as PDF from Write or Draw, a blue 45-45-90 triangle (irrespective of the slope angle of the title bar) appears at the bottom left of the bar as if the shape extended to the corner.

The vector was created in Draw as a polygon. I have also modified the nodes on a a square shape to create the same shape, but it suffers from the same problem.

I can't tell if this is the same bug as #37830.
Comment 1 Christian Lohmaier 2011-12-29 07:09:04 UTC
confirming with 3.5.0beta2 on linux(64bit)
Comment 2 tester8 2012-01-31 07:44:04 UTC
Reproduced with

LOdev 3.5.0rc2
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI

Let's make it NEW :)
Comment 3 ign_christian 2013-06-18 09:36:50 UTC
Created attachment 80991 [details]
PDF result from LO 4.0.4.2

It's almost correct with LO 4.0.4.2 (Win7 32bit)
Comment 4 Johann 2014-07-07 09:59:11 UTC
Created attachment 102364 [details]
PDF file with artifacts at corners in version 4.2.5.2
Comment 5 Johann 2014-07-07 10:00:21 UTC
Additional artifacts still available on PDF export.
Draw has the same problem, also on EPS export.

Version: 4.2.5.2
Windows 7 Prof. x64
Comment 6 Johann 2014-08-20 08:04:37 UTC
Created attachment 104964 [details]
Bug is still available in version 4.3.0.4

Bug is still available in version 4.3.0.4 but does not appears under all operating systems.
Under MAC OS, iOS and Android is the PDF file clean, without dots in the corners.

Therefore I attached a PNG file.
Comment 7 QA Administrators 2015-09-04 02:48:28 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 8 Buovjaga 2015-11-19 10:32:06 UTC
Not seeing any artefacts. WFM.

If you still see them, set back to NEW.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 66d2b72667792cb18b25805387824d636e2a455c
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-18_02:35:53
Locale: fi-FI (fi_FI)