Download it now!
Bug 43927 - EDITING Forms - tabulator for tablecontrol in subforms not removable
Summary: EDITING Forms - tabulator for tablecontrol in subforms not removable
Status: RESOLVED DUPLICATE of bug 51727
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-18 06:20 UTC by Robert Großkopf
Modified: 2016-01-29 18:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
2 forms - one with auto-sorted tabulator. Tabulator to subform not removable. (20.58 KB, application/vnd.sun.xml.base)
2012-05-01 00:02 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2011-12-18 06:20:37 UTC
If you want to get from a mainform to a tablecontrol in a subform you have to choose the automatic sequence of tabulators.
When you put another tablecontrol in the subform you could not change the tabulator-sequence.
Comment 1 sasha.libreoffice 2012-04-30 04:42:49 UTC
Thanks for bugreport
Please, attach document that demonstrates this problem
Comment 2 Robert Großkopf 2012-05-01 00:02:06 UTC
Created attachment 60824 [details]
2 forms - one with auto-sorted tabulator. Tabulator to subform not removable.

First form: Tabs are sorted by position. When moving through a form the tabulator only works in the main-form.
Second form: Tabs are sorted by automatic sorting. When moving through a form the tabulator works in main-form and subform. Most people wish this behaviour. When adding another subform and you wish, that the tabulator should go to the second subform, not to the first, you could not remove the tabulator from the first subform.
Only way to remove a tab from a subform is to delete the subform.
Could be a good idea to change tabulators in form and subforms manually, not only with "automatic sorting".

Robert
Comment 3 sasha.libreoffice 2012-05-02 03:38:44 UTC
Thanks for attachment
Comment 4 sasha.libreoffice 2012-05-02 03:39:55 UTC
@ Lionel
What do You think about this bug?
Comment 5 Alex Thurgood 2015-01-03 17:40:53 UTC
Adding self to CC if not already on
Comment 6 QA Administrators 2016-01-17 20:04:13 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT:

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-01-17
Comment 7 Robert Großkopf 2016-01-29 18:19:26 UTC
Bug could be solved with another bug:
https://bugs.documentfoundation.org/show_bug.cgi?id=51727

Tablecontrol is set to tabstop "no". If set to "yes" and the form is saved nothing will change. But if set to "no" after setting to "yes" the tabulator for the tablecontrol in the subform will be removed.

I will set this one as a duplicate of 51727.

*** This bug has been marked as a duplicate of bug 51727 ***