Bug 43991 - SVG: native support instead of import
Summary: SVG: native support instead of import
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.5.0 Beta1
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2011-12-20 13:01 UTC by Fabian Alexander Wilms
Modified: 2018-06-20 17:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
The opened and imported SVG (155.65 KB, image/png)
2011-12-20 13:01 UTC, Fabian Alexander Wilms
Details
example inserts as bitmap but does not import (87.59 KB, image/svg+xml)
2012-01-17 13:15 UTC, mathog
Details
SVG-Test File without Opacity and Blur (20.65 KB, application/zip)
2012-03-25 14:11 UTC, ChrisWe
Details
SVG-Test File with Opacity and Blur (20.92 KB, application/zip)
2012-03-25 14:15 UTC, ChrisWe
Details
SVG-Test File without Opacity and Blur (102.46 KB, image/svg+xml)
2015-12-09 10:57 UTC, Xisco Faulí
Details
SVG-Test File with Opacity and Blur (104.26 KB, image/svg+xml)
2015-12-09 10:57 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Alexander Wilms 2011-12-20 13:01:01 UTC
Created attachment 54611 [details]
The opened and imported SVG

Problem description: 

Even though imported SVGs are displayed flawlessly in LO, opening is still problematic. OpenOffice now has native support for SVGs (http://eric.bachard.org/news/index.php?post/2011/12/03/In-progress-%3A-native-support-of-the-SVG-graphic-format-in-Apache-OpenOffice.org), so I wondered whether LO could make use of this code as soon as the licensing stuff is done. I don't know whether this should be used for importing SVGs, too or only opening them in draw.

Steps to reproduce:
1. Open Draw
2. Import SVG via Insert => Picture => From file
3. Open the same SVG via File => Open

Current behavior:
The imported file looks as expected but cannot be edited. The editable SVG is broken.

Expected behavior:
The opened SVGs should look like the imported one. Copying the OpenOffice code would solve this issue.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 Rainer Bielefeld Retired 2011-12-20 22:44:48 UTC
I see the promising marketing, but are there any more neutral test results?

@Thosrsten:
May be there are already own efforts into the same direction? That's the first new thing in AOOo where I believe we should think about an integration.
Comment 2 Thorsten Behrens (CIB) 2011-12-22 15:39:40 UTC
Well, not for 3.5.0. Let's see how things pan out the other side then - from first looks, there's no open-in-Draw implemented (though Insert, and then break-up should work)
Comment 3 Fabian Alexander Wilms 2011-12-22 15:49:49 UTC
Opening in Draw definitely is implemented; also the options to break up a grouping are deactivated when an inserted SVG is selected.
Comment 4 Thorsten Behrens (CIB) 2011-12-22 15:56:10 UTC
(In reply to comment #3)
> Opening in Draw definitely is implemented; also the options to break up a
> grouping are deactivated when an inserted SVG is selected.
>
This is referring to what, AOO(I)?
Comment 5 Fabian Alexander Wilms 2011-12-22 16:03:18 UTC
No, LibreOffice 3.5.0, Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4
Comment 6 mathog 2012-01-17 13:15:46 UTC
Created attachment 55696 [details]
example inserts as bitmap but does not import

The attached file is typical of the problems I run into.  With 3.5.0b2 on Windows
insert will bring this in as a bitmap - which is useless to me.  File->open throws
a general error.  Net result, no way to import the drawing as objects into 3.5.0b2.  3.4.4 had the same open problem, but it could insert it (partially, the pieces it did bring in stayed as objects).
Comment 7 ape 2012-03-17 08:54:00 UTC
LOdev-3.5.2rc0+; ID: 90e2949-73cb0b8-f269e46
OS: Win_NT-5.1;-5.2;-6.1
Maybe I'm wrong, but the error appears every time when I open an SVG file that contains the text layer.
P.S. The text layer can be lost too when you inserted a picture from the SVG file. But that is another bug.
Comment 8 ChrisWe 2012-03-25 14:11:27 UTC
Created attachment 59036 [details]
SVG-Test File without Opacity and Blur

SVG support in LibO seems to be complex. I'm having similar problems like in this LibreOfficeForum.org Thread: http://en.libreofficeforum.org/node/293 

Post #15 (Sun, 25 Mar 2012 - 10:40 PM) is interesting and actual: I also use LibO Win7x32 3.5.1.2 Writer and are not able to import the SVG-Test File and export it to a PDF without total conversion to bitmap image.
Comment 9 ChrisWe 2012-03-25 14:15:51 UTC
Created attachment 59038 [details]
SVG-Test File with Opacity and Blur

I have added also the original SVG-Test File with Opacity and Blur. I also think even with this objects/filters in the SVG a good LibO support for vector-export to PDF should be reached.
Comment 10 Gerry 2013-04-30 08:34:13 UTC
Wasn't this bug fixed in LibreOffice 4.0? You can import and insert SVG files. When inserting, the layout is best preserved, but you cannot edit it anymore. When importing it, it is converted to a LibreOffice drawing and can be edited (but might not import everything). So, this bug is fixed then?

I am not saying that the import of SVG files works flawlessly in LibreOffice. I actually have many problems that something is not imported correctly. But for theses problems, we should open other bug entries?
Comment 11 Thorsten Behrens (CIB) 2013-09-12 16:14:39 UTC
Apologies for not having gotten around fixing this bug yet; unfortunately in future I'll have even less time at my disposal for this, so I'm freeing up ownership for other volunteers to take over.
Comment 12 A (Andy) 2015-04-05 20:33:54 UTC
Reproducible with LO 4.4.1.2, Win 8.1

If you open the attached sample SVG then several parts of it are not shown correctly.
Comment 13 Xisco Faulí 2015-12-09 10:57:18 UTC
Created attachment 121162 [details]
SVG-Test File without Opacity and Blur
Comment 14 Xisco Faulí 2015-12-09 10:57:46 UTC
Created attachment 121163 [details]
SVG-Test File with Opacity and Blur
Comment 15 Robinson Tryon (qubit) 2015-12-10 05:36:22 UTC
Migrating Whiteboard tags to Keywords: (filter:svgOpen)
Comment 16 V Stuart Foote 2016-06-21 16:02:29 UTC
The SVG open to Draw filter will be dropped in favor of more functional svgio insert filter which will be modified for use to open SVG into draw.

Issue(s) here are already well handled by the svgio filter.

Resolving WONTFIX

=-discussion-=

http://nabble.documentfoundation.org/Two-svg-import-filters-tc4165365.html
http://nabble.documentfoundation.org/Two-svg-import-filters-tc4165248.html

ESC decision
http://nabble.documentfoundation.org/Libreoffice-qa-minutes-of-ESC-call-tc4171063.html

* SVG import filters (Thorsten)
    + proposal: rip out old Thorsten + Fridrich filter.
       + Xisco, Regina and Christina kindly helped.
          + but still not so great at rendering SVGs.
    + Armin's SVGIO seems better for now
       => deprecate in favour of svgio; save 2-3k LOC.
    + still 1-2 gerrit patches there (Michael S)
       + bit of a shame.
    => announce deprecation & removal of it in 5.2 timeframe
AI:    + and CC & thank explicitly those who worked on this. (Thorsten)