Bug 44066 - Diagram data table window has no close button when started using gnome shell
Summary: Diagram data table window has no close button when started using gnome shell
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-22 08:54 UTC by deichblach
Modified: 2015-07-28 20:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot of the diagram data table window (104.77 KB, image/png)
2011-12-22 08:54 UTC, deichblach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deichblach 2011-12-22 08:54:13 UTC
Created attachment 54706 [details]
screenshot of the diagram data table window

If creating a diagram in LibreOffice Writer using gnome shell and trying to edit the underlying data table, the data table window provides no button to close the window. This tends to irritate the user.

Steps to reproduce:
1. Open LibreOffice Writer
2. Insert->Object->Diagram
3. Right click on the diagram -> choose "Diagrammdatentabelle" (should be "diagram data table" in english)
-> The window has no close button next to the window title. (see attached screenshot)

Firefox had a similar issue under gnome shell -> https://bugzilla.mozilla.org/show_bug.cgi?id=608934
Comment 1 sasha.libreoffice 2012-03-07 03:31:17 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
And which Gnome used: 2 or 3?
Comment 2 deichblach 2012-03-27 02:11:29 UTC
I was able to reproduce this bug with LibreOffice Writer 3.5.1.2.

I'm using Gnome 3 (hence referring to Gnome Shell).
Comment 3 deichblach 2012-03-27 02:12:28 UTC
changed affected version number
Comment 4 sasha.libreoffice 2012-03-27 04:04:22 UTC
Sorry, but "Verison" is most early reproducible version, not current version
Changing again to 3.4.4
Comment 5 Javier Silva 2012-04-22 09:55:20 UTC
[Reproducible] with "LibreOffice 3.4.4  - Ubuntu 11.10 (64bit) Spanish
UI"

I do the same steps and I have the same problem.
Comment 6 sasha.libreoffice 2012-04-25 09:41:29 UTC
Due to last comments, changing status to New
Comment 7 Joel Madero 2015-05-02 15:44:11 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 8 Jeff Fortin Tam 2015-07-28 20:01:30 UTC
With version 4.4.4.3 on Fedora 22, there are some buttons at the bottom of the dialog now: OK, Cancel, Help.