Bug 44097 - List of printers does not appeared automatically in dialog printing box
Summary: List of printers does not appeared automatically in dialog printing box
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86 (IA32) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-23 08:47 UTC by Rpnpif
Modified: 2012-07-16 03:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rpnpif 2011-12-23 08:47:58 UTC
On Debian Squeeze.
Disconnect a Cups compatible printer from network (for example a HP4280).
Launch Libreoffice 3.4.4 and open a document to print.
Reconnect the printer to the network.
Wait that this printer is visible with "lpstat -t".
Open the dialogue printing box. Only the generic printer is shown, not the HP printer.
Only opening a new instance of LO or the Printer settings menu in the actual instance allow to show the printer name and now printing is possible. This is not ergonomic.

The wished enhancement : updating the list of network printers automatically (or, less good, with a button in the dialog printing box), without the need to open the printer settings menus.
Comment 1 Joel Madero 2012-07-13 16:49:50 UTC
I'm going to have to look into this one to see if it's our bug. I have seen similar behavior with a lot of packages in Linux and indeed....it's annoying. It may be an issue with CUPS or some other package since I see it so often, or maybe just every package has missed the option for auto refresh. I'll investigate a bit and mark accordingly soon
Comment 2 Joel Madero 2012-07-16 03:33:45 UTC
This isn't our bug, LO uses the gtk backend call to get printer info. Thanks for the input, I may try to find out the exact package to see if someone else will fix this but will be closing it here.