Bug Hunting Session
Bug 44221 - EDITING: comments are deleted in writeprotected sheets
Summary: EDITING: comments are deleted in writeprotected sheets
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Calc-Comments
  Show dependency treegraph
 
Reported: 2011-12-28 07:09 UTC by h.kant
Modified: 2017-04-14 09:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Protect Sheet in MSO (34.21 KB, image/jpeg)
2017-04-13 14:03 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description h.kant 2011-12-28 07:09:01 UTC
Problem description: 

Steps to reproduce:
1. create a comment
2. unprotext cell
3. writeprotect sheet
4. write number oder character in cell
5. delete number or character
6. comment is deleted too

Current behavior (all versions):
In spite of write-protection of a sheet, comments in unprotected cells are deleted with the del-key. The backspace-key deletes the comments too, but the user is asked for permission before. LibreOffice deletes comments with the del-key, even if deleting at backspace-dialog is disabled.
LibreOffice does not keep this setting of backspace-key, after restarting LibreOffice. 


Expected behavior:
Never delete comments in write-protected sheets (standard in excel)

Platform (if different from the browser): windows, linux
              
Browser: Opera/9.80 (X11; Linux i686; U; de) Presto/2.10.229 Version/11.60
Comment 1 sasha.libreoffice 2012-05-03 04:23:55 UTC
Thanks for new idea
described behaviour reproduced in 3.5.3. This may be improved. Users may not expect that comments will be deleted in protected document.
Comment 2 Timur 2015-11-17 19:38:02 UTC Comment hidden (obsolete)
Comment 3 gmolleda 2016-10-18 10:50:20 UTC
I think there should be an option to "[] The user can delete comments in unprotected cells" to protect a sheet.

English discriminates by nationality and income, Esperanto is better as an international language.

Creo que debería haber una opción para "[ ] Usuario puede borrar comentarios en celdas desprotegidas" al proteger una hoja.

Mi pensas ke devus esti eblo por "[] La uzanto povas forviŝi komentojn en neprotektata ĉeloj" kiam vi protektas folion.
Comment 4 Timur 2017-04-13 13:59:56 UTC
(In reply to h.kant from comment #0)
> Current behavior (all versions):
> In spite of write-protection of a sheet, comments in unprotected cells are
> deleted with the del-key. The backspace-key deletes the comments too, but
> the user is asked for permission before. LibreOffice deletes comments with
> the del-key, even if deleting at backspace-dialog is disabled.
Referring to https://help.libreoffice.org/Calc/Deleting_Contents#Comments:
Sheet - Clear Cells specifies the contents to be deleted from the active cell or from a selected cell range. This dialog is also called by pressing Backspace after the cell cursor has been activated on the sheet.
Pressing Delete deletes content without calling the dialog or changing formats.
"Del" deletes the whole contents both in unprotected sheet and in unprotected cell of protected sheet.
 
> Expected behavior:
> Never delete comments in write-protected sheets (standard in excel)
Without argumentation that would justify that, I consider current LO behavior better: use Backspace or Delete for different behavior. 

(In reply to gmolleda from comment #3)
> I think there should be an option to "[] The user can delete comments in
> unprotected cells" to protect a sheet.
That would ask for similar from "Delete Contents": text, numbers, formulas...
This may be required but as a whole idea, not item by item. 
I'll add screenshot from MSO which shows various options, and comment is not one of them.

I consider the current behavior normal and intuitive: contents of unprotected cells is deleted.
I close as WontFix. I kindly ask Heiko to comment if I'm wrong.
Comment 5 Timur 2017-04-13 14:03:12 UTC
Created attachment 132542 [details]
Protect Sheet in MSO

Form can be scrolled and not resized so the whole contents is in 2 images.
Comment 6 Heiko Tietze 2017-04-14 09:01:31 UTC
(In reply to Timur from comment #4)
> I close as WontFix. I kindly ask Heiko to comment if I'm wrong.

Two slightly different ways to deal with content, delete and backspace. The current behavior makes sense to me even when the effect is not clear before execution. But both can be undone so there is no potential data loss.

On the other hand it was about deletion of comments in _write-protected sheets_. Cannot reproduce that with 5.3 - adding numbers to protected sheets is not possible - but agree that deletion of comments (and other content) for read-only data must be protected.