Download it now!
Bug 44269 - PRINTING: Printing problem with form contains text field with «Multi-line with formatting »
Summary: PRINTING: Printing problem with form contains text field with «Multi-line wi...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.5.0 Beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 52613 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-29 05:33 UTC by Tribunal Federal
Modified: 2015-03-05 05:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
1 sample document (odt), the result and screenshot of editing control into the form (345.54 KB, application/zip)
2011-12-29 05:33 UTC, Tribunal Federal
Details
Edited copies of form_test.odt under different platform/LO as well as corresponding generated PDFs. (535.71 KB, application/zip)
2013-05-06 04:44 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tribunal Federal 2011-12-29 05:33:34 UTC
Created attachment 54936 [details]
1 sample document (odt), the result  and screenshot of editing control into the form

Some fields are hidden when printing the document  which contains form with a  «Multi-line with formatting » text field.

Steps to reproduce:

1) Open and print the attached document (form_test.odt)
2) Note that some fields are hidden  (see result.pdf)
3) Edit the design of form and replace the properties of some field/Control text type «Multi-line with formatting » with « Multiline » especially for TextBoxStart, TextBox and TextBox1 (see Design_Editing.png)
4) Note that here the printing works well

Expected behavior:

Using  « multi-line with formatting »  and printing it correctly.
Comment 1 Owen Genat (retired) 2012-08-01 10:10:42 UTC
*** Bug 52613 has been marked as a duplicate of this bug. ***
Comment 2 Jean-Baptiste Faure 2012-08-01 10:33:55 UTC
(In reply to comment #1)
> *** Bug 52613 has been marked as a duplicate of this bug. ***

Indeed. Failed to find this bug report because of component. I suggest to change it for "Printing and PDF export".

Best regards. JBF
Comment 3 A (Andy) 2013-04-30 20:53:26 UTC
Could you please give more information about your reported bug and/or retest it with the latest release of LO.  I am not sure if I already understand it right.
I tried it with LO 4.0.2.2 (Win7 Home, 64bit).  I have no fields hidden.  But what I experienced is that if I print it, then the text in the text box at the bottom ("TextBox1") is printed without a line break and it is no longer bold.  After changing to "Multi-line" it is printed with line break.

Steps Done:
1. Open WRITER
2. Open the attachment "form_test.odt"
3. Print the document
4. Go to VIEW -> TOOLBARS and activate FORM CONTROLS and FORM DESIGN
5. Open FORM NAVIGATOR in the bottom toolbar
6. Activate the DESIGN MODE ON/OFF in the bottom toolbar
7. In the FORM NAVIGATOR go with the left mouse click for instance to the element "TextBox1"
8. Right mouse click on the text box in the document and go to CONTROL
9. Go to the tab GENERAL and go down to TEXT TYPE and change to "Multi-line" and close the dialog box
10. Print the document
Comment 4 Owen Genat (retired) 2013-05-06 04:44:34 UTC
Created attachment 78898 [details]
Edited copies of form_test.odt under different platform/LO as well as corresponding generated PDFs.

Setting Component to "Printing and PDF Export" as per suggestion in comment #2. This would appear to be consistent with the bug title.

I agree with comment #3 and recommend closing this bug as TDF/LO v4.0.2.2 under Ubuntu 10.04 x86_64, MacOS 10.6.8, and Win7HP, no longer produces the field overflow indicated in the original report. Under TDF/LO v3.5.7.2 the overflow is clearly apparent as originally reported. 

The problem fields in the original report were TextBoxStart, TextBox, TextBox1 (as indicated) and the first pair of OPEN_DOSS1 fields. Regardless of whether these are set to use a Type type of "Multi-line" or "Multi-line with formatting", the results under v4.0.2.2 are that the fields display as expected. Please refer the files in the attached ZIP. All PDFs ending with "_multi-line_with_formatting" are generated from the original ODT in comment #0. All PDFs ending with only "_multi-line" are generated from the corresponding enclosed ODT, which has had the fields mentioned edited as described.

Under MacOS and Win7HP the original formatting does not appear to be retained. I am not sure why this is the case but it may be an artefact of the different method of PDF generation used on those platforms. In any case it is a separate matter from the original report.
Comment 5 Owen Genat (retired) 2013-05-06 04:46:56 UTC
Previous comment #4 did not set the Component accordingly due to upload of attachment. Setting it now.
Comment 6 QA Administrators 2015-03-04 02:22:20 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 7 Jean-Baptiste Faure 2015-03-05 05:59:51 UTC
As already stated in comment #4 there is no field overflow problem with this form.

I reproduced the same steps as in comment #3 without problem.

Tested with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF