Bug 44300 - : ibus not working without LANG
Summary: : ibus not working without LANG
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-29 18:24 UTC by Ryo Furue
Modified: 2012-06-07 21:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryo Furue 2011-12-29 18:24:01 UTC
Problem description: ibus cannot be enabled on Libreoffice Writer unless the env.var. LANG is set for Writer.

Steps to reproduce:
1. Launch Writer.
2. Try to enable ibus by pressing the hotkey of iubs.
3. ibus is not enabled.

Current behavior: If Writer is launched like

  $ LANG=ja_JP.UTF-8 lowriter

ibus works.  Without LANG, ibus doesn't work.

Expected behavior: In the cooperation with ibus and other IMEs, Libreoffice shouldn't depend on LANG.  ibus and other IMEs use a plugin architecture so that the user can switch input languages on the fly. For example, you can type Chinese, Vietnamese, Korean, etc. at the same text cursor without restarting ibus.  Then, what LANG should we use for Libreoffice?  No, that's not how Libreoffice should work. In fact, other applications (Firefox, emacs, gnome-terminal, etc.) work with ibus and other IMEs without the env.var. LANG.

Platform (if different from the browser): 
              
Browser: Opera/9.80 (X11; Linux i686; U; en) Presto/2.10.229 Version/11.60
Comment 1 sasha.libreoffice 2012-02-16 02:09:03 UTC
@ Kohei
Sorry for interrupt, but, please, take look at this bug, if have time. I have not enough knowledge to reproduce this bug.
Comment 2 Kohei Yoshida 2012-02-16 06:16:55 UTC
Well, ibus is working fine for me (for Japanese input).  I'm on openSUSE 12.1.  Using the distro-provided libreoffice 3.4.4.  I don't set LANG manually, but system sets LANG to en_US.UTF-8.

Perhaps it's a distro-specific, or maybe DE-specific (I use GNOME 3).
Comment 3 Kohei Yoshida 2012-02-16 06:19:04 UTC
It also works fine with my stock development build.  So it's not due to some distro-specific fixes.
Comment 4 Kohei Yoshida 2012-02-16 06:23:15 UTC
To be more specific, my system language is US English, and I only enable Japanese Anthy input in ibus.  Then my hot key is Ctrl-space.
Comment 5 sasha.libreoffice 2012-02-16 06:24:55 UTC
@ Kohei
Thanks for help
Comment 6 Ryo Furue 2012-02-16 11:29:23 UTC
Hi folks,

Please compare these two cases:

  $ LANG= lowriter

and

  $ LANG=ja_JP.utf-8 lowriter

if you use sh/ksh/bash .  The appropriate LANG value for the second case may be different for you.  If you normally use EUC-JP, then it should be "ja_JP.eucJP" or something like that.

My point is NOT whether ibus works or not.  My point is that ibus does not work when LANG is not set.  And I think that is a bug.

Just in case, if you use csh/tcsh, compare

  % env LANG= lowriter

with

  % env LANG=ja_JP.utf-8 lowriter

Cheers,
Ryo
Comment 7 Kohei Yoshida 2012-02-16 11:47:56 UTC
(In reply to comment #6)
> Hi folks,
> 
> Please compare these two cases:
> 
>   $ LANG= lowriter
> 
> and
> 
>   $ LANG=ja_JP.utf-8 lowriter

I tried both, and I was able to type in Japanese in both cases.

> My point is NOT whether ibus works or not.  My point is that ibus does not work when LANG is not set.  And I think that is a bug.

Sorry.  I still can't reproduce it.

What distro do you use, and what desktop environment are you in?  Maybe that will help narrow down the problem.
Comment 8 Ryo Furue 2012-02-16 11:59:26 UTC
Thank you for the response!!

> What distro do you use, and what desktop
> environment are you in?  Maybe that will help
> narrow down the problem.

I use the "testing" distribution of Debian.  My desktop environment is LXDE.  I don't know what other information may be useful.

I wonder whether the environment of ibus matters or not.  I've checked what LANG value my ibus-daemon has:

  $ cat /proc/5774/environ | tr '\0' '\n'

where the process number is that of /usr/bin/ibus-daemon ,
and I find "LANG=C".

Cheers,
Ryo
Comment 9 Joel Madero 2012-06-07 21:55:54 UTC
I'm marking this as NOTOURBUG because IBUS has consistently worked for multiple people including myself. Feel free to continue updating this but as far as I can tell this is specific to your setup and isn't a bug in LO.