Bug Hunting Session
Bug 44350 - Writer FILEOPEN: Defined page numbers not preserved on RT from saved DOC
Summary: Writer FILEOPEN: Defined page numbers not preserved on RT from saved DOC
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: implementationError
Depends on:
Blocks:
 
Reported: 2011-12-31 08:44 UTC by Cecil New
Modified: 2017-05-23 07:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Results of doing steps above. Both the original ODT file and the DOC file with the bug (8.42 KB, application/zip)
2011-12-31 08:44 UTC, Cecil New
Details
doc file produced from attached odt file using msWord 2007 (22.50 KB, application/msword)
2012-05-03 07:22 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cecil New 2011-12-31 08:44:23 UTC
Created attachment 55008 [details]
Results of doing steps above.  Both the original ODT file and the DOC file with the bug

Problem description: Defined page numbers are not preserved after a SAVE-AS to Win XP DOC format

Steps to reproduce:
1. Open new document
2. Write a paragraph or two
3. Insert footer
4. Insert field for page number
5. Right justify
6. Click to beginning of paragraph
7. Click Format, Paragraph, Text Flow, Insert, With Page Style
8. Set page number to 400
9. Save document and exit
10. Open document and note page number is 400
11. Click File, Save As Win XP / 2003 format
12. Exit
13. Open ".doc" document
14. Note page number is now 144

Current behavior:

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Ubuntu/11.10 Chromium/15.0.874.106 Chrome/15.0.874.106 Safari/535.2
Comment 1 Vicente Rafael Estévez Vacas 2012-04-15 10:53:08 UTC
[Reproducible] with "LibreOffice 3.5.2.2 - Windows XP (32bit) Spanish
UI"
[Reproducible] with "LibreOffice 3.4.6 - Debian Squeeze (32bit) Spanish
UI"

In both cases the page number in the new doc file is 144.
Comment 2 sasha.libreoffice 2012-05-03 07:21:46 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit and Windows 7 32 bit
document saved correctly to doc format
Opening doc format is incorrect, page number becomes wrong. It is FILEOPEN problem.

Changing version to 3.3.4 as most early reproducible
Comment 3 sasha.libreoffice 2012-05-03 07:22:46 UTC
Created attachment 60972 [details]
doc file produced from attached odt file using msWord 2007
Comment 4 Jorendc 2013-02-17 17:37:49 UTC
Still reproducible using LibreOffice 4.0.0.
Comment 5 QA Administrators 2015-02-19 15:47:07 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-03-08 18:21:18 UTC
Reproduced.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 7 Timur 2016-04-07 10:59:05 UTC
RT=roundtrip, save and reopen
Very well defined bug, pity it's not solved.
Comment 8 QA Administrators 2017-05-22 13:20:07 UTC Comment hidden (obsolete)
Comment 9 Timur 2017-05-23 07:45:24 UTC
Looks like resolved somewhere in 5.2.