Bug 44375 - EDITING: Sorting by alphabet omits first row
Summary: EDITING: Sorting by alphabet omits first row
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-01 15:05 UTC by Alexander Wilms
Modified: 2012-01-02 09:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Wilms 2012-01-01 15:05:38 UTC
Problem description: 

When one tries to sort a list of words, the word in the first row stays there.

Steps to reproduce:
1. Enter a in cell A1, b in A2 and c in A3
2. Select those 3 cells
3. Click on the 'Sort descending' button (Or similar)

Current behavior:

The result is this

a
c
b

Expected behavior:

c
b
a

Platform: 
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 Rainer Bielefeld Retired 2012-01-01 21:51:18 UTC
Effect is reproducible with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta2- WIN7 Home Premium (64bit) German UI [Build-ID : 8589e48-760cc4d-f39cf3d-1b2857e-60db978], but it's a feature, not a bug.

@Alexander Wilms:
I am pretty sure that in "sort by" you saw "a" instead "A1"? That means in Tab "Options" "'Range contains column labels' is checked. So "a" is aour column label. and everything you describe is correct.
Comment 2 Alexander Wilms 2012-01-02 09:23:21 UTC
Yes, I saw this option in the dialogue. But unchecking it isn't persistent. And what would most people expect? I reported this because someone on the LO Facebook page had a problem, so I wonder whether this behavior is LO specific or if Excel works the same.