Bug Hunting Session
Bug 44457 - FILEOPEN: Docx import filter doesn't recognize page orientation correctly
Summary: FILEOPEN: Docx import filter doesn't recognize page orientation correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-04 11:14 UTC by pieter kristensen
Modified: 2014-10-22 07:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pieter kristensen 2012-01-04 11:14:11 UTC
Problem description: 

Steps to reproduce:
1. Open this document http://members.ziggo.nl/enouwens/permanente%20dingen/odt-docx/kubus.docx . All versions of Libreoffice so far render the page orientation as portrait while it should be landscape. For reference the orriginal file, which I wrote in .odt http://members.ziggo.nl/enouwens/permanente%20dingen/odt-docx/kubus.odt. I converted this document to docx using MSO2010. MSO renders the .odt document 100% correctly.


Current behavior: Libreoffice (all versions) show document page orientation as portrait.

Expected behavior: Libreoffice shows document page orientation as landscape.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 1 Cor Nouws 2012-01-08 13:41:15 UTC
thanks Pieter for filling this issue.
I can confirm the wrong behaviour for the linked file.

However, when I create a new .odt in 3.4.5, landsccape, two columns, save as .docx
and then open again
the page is show correct > as landscape.

Are you able to reproduce the bug with a new / oher file?

(Tested in OOo 3.2.1 / 3.3.0 and 3.4.0DEV too - have the same problem)
Comment 2 pieter kristensen 2012-01-08 22:46:31 UTC
In addition to your tests I looked a little further:
When I create a simple text file with two columns (landscape) in LO and save as .docx it is rendered correctly by MSO 2010. Also when I create a simple text file with two columns in MSO 2010 and save it as .docx it is rendered correctly in LO.

BUT when I load in MSO 2010 the "kubus" text (docx version) from the link in this bug report, and then save save it again under another name as .docx it still rendered wrong in LO.
I have no clue why. Of course it should also be rendered correctly.
Comment 3 A (Andy) 2013-05-03 22:10:43 UTC
as per the comments I can confirm the strange behavior

reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 4 Jorendc 2014-02-14 12:46:57 UTC
@Pieter: you mind re-attaching the mentioned test-document? Looks like it isn't downloadable anymore, using provided links.

Marking as NEEDINFO. Please mark as 'NEW' again when you provided this information.

Thanks!
Joren
Comment 5 pieter kristensen 2014-02-14 13:37:41 UTC
I uploaded the files to the same location. The old links work again!
Thank you
Pieter
Comment 6 Buovjaga 2014-10-08 08:50:57 UTC
kubus.docx opens in landscape orientation for me on Win 7 64-bit 4.3.2.2 and dev build Version: 4.4.0.0.alpha0+
Build ID: 276a046d5256b14478ab283f420654df6ae76b55
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-08_00:21:52