Download it now!
Bug 44529 - FILESAVE FILEOPEN RTF: Special Characters are saved incorrect when saved as RTF under Windows
Summary: FILESAVE FILEOPEN RTF: Special Characters are saved incorrect when saved as R...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other Windows (All)
: medium major
Assignee: Miklos Vajna
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-06 06:29 UTC by peter.hermsdorf
Modified: 2015-03-06 05:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
copyright sign with arial (1.65 KB, application/msword)
2012-01-10 01:33 UTC, peter.hermsdorf
Details
copyright sign with times new roman (1.66 KB, application/msword)
2012-01-10 01:34 UTC, peter.hermsdorf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter.hermsdorf 2012-01-06 06:29:45 UTC
Problem description: 
special characters are encoded incorrect when saved as RTF under Windows



Steps to reproduce:
1. create new empty file with writer
2. Insert special character: Menu Insert -> Special Character
3. Choose e.g. the Copyright Sign
4. Save file as RTF
5. Close the document
6. reopen the saved RTF document

Current behavior:
wrong character displayer

Expected behavior:
original character should be dispayed eg. the Copyright Sign

Platform: 
              
Windows 7 64 Bit
reproduced with the following LibreOffice Versions:

3.4.3 final
3.4.4 final
3.5.0.beta2

works with version 3.4.4 under Ubuntu Linux 64 bit
Comment 1 s-joyemusequna 2012-01-08 10:23:26 UTC
Confirmed (Platform Windows Vista 64)
Comment 2 Jean-Baptiste Faure 2012-01-09 21:59:03 UTC
Which font did you use ? Calibri ? Have you tried to play with different standard font like Arial, Times New Roman, etc.

Best regards. JBF
Comment 3 peter.hermsdorf 2012-01-10 01:00:00 UTC
the error occurs with Times New Roman (which is the default font)

i tried with Verdana and Arial which seems to work ok

any ideas?
Comment 4 peter.hermsdorf 2012-01-10 01:33:57 UTC
Created attachment 55372 [details]
copyright sign with arial
Comment 5 peter.hermsdorf 2012-01-10 01:34:28 UTC
Created attachment 55373 [details]
copyright sign with times new roman
Comment 6 peter.hermsdorf 2012-01-10 01:34:59 UTC
i compared the .rtf source that is saved in both cases:

when switching the font to Arial the copyright sign is saved as 

\u169\'a9}
(line 16 in attached arial.rtf)

when saving the same sign with times new roman the rtf looks like

\'a9}

(also line 16 in attached timesnewroman.rtf)

when manually adding the missing \u169 to the rtf source in timesnewroman.rtf the sign is displayed correctly
Comment 7 Jean-Baptiste Faure 2012-01-10 05:31:04 UTC
I reproduce the problem with LibreOffice 3.4.5 rc2, LO 3.5.0 beta2 and LO3.5.0 beta2+ (daily build : LOdev 3.5.0beta2+ Build ID: cbb7814-7f15fca-9e804be-2d9b003) under MS-Windows-XP (VM)

But *not* with LO 3.4.5 rc2 under Ubuntu 10.04 (x86) and LO 3.5.0 beta2+ under Ubuntu 11.10 (x86_64)

So it seems it is a MS-Windows only problem.

Miklos: i think it is for you. Please feel free to reassign if you can't handle this bug. Thank you :-)

Best regards. JBF
Comment 8 Urmas 2012-01-12 09:47:07 UTC
For some crazy reason the inserted character with no additional formatting applied gets the font with SHIFTJIS_CHARSET (128). Why?
Comment 9 Miklos Vajna 2012-01-12 09:52:01 UTC
Urmas,

Can you see if this export bug also happens with docx? Just to see where the bug is.

Thanks.
Comment 10 Arnaud Versini 2012-01-14 06:22:44 UTC
I will check if this bug is stil on windows, special characters was a problem on Linux byut not anymore
Comment 11 peter.hermsdorf 2012-01-24 00:53:50 UTC
anything new on this?

can i help on something?
Comment 12 sundoulos2 2012-01-24 06:03:28 UTC
The issue is still present in 3.5.0 RC1, Kubuntu 11.10, WINE 1.3.37. Here's how to reproduce:

1. Start a new document in Writer.
2. Type in some text. It can be any text, not just special characters. Font selection doesn't matter either.
3. Copy the text to the clipboard.
4. Paste into ActionTest editor. (ActionTest can be downloaded from:
http://trichview.com/resources/actions/actiontest.zip)
5. Save as rvf.
6. Assigned charset is SHIFTJIS_CHARSET.

If I go to Format/Character/Font/Language in LO, Japanese isn't listed; the only languages available in Country/Region & Language under Kubuntu's System Settings are American English and British English. So,... no obvious reason for SHIFTJIS.
Comment 13 Miklos Vajna 2012-01-25 04:37:37 UTC
Hi,

I tried to reproduce this, indeed it's specific to RTF and Windows. (However the relevant part of the RTF export filter is really simple, there is nothing RTF or Windows-specific there...) I guess a solution is to do the same what we do on Linux when the locale is UTF-8 (emit the unicode character instead of playing with charset), but I don't have a Windows build around.

Will try to get a mingw build soon - hopefully reproducible there.

Miklos
Comment 14 peter.hermsdorf 2012-02-07 05:53:53 UTC
any progress on this issue?
Comment 15 Miklos Vajna 2012-02-07 05:58:49 UTC
Not really. I don't have a Windows build environment (I plan to set up one in the next few weeks) and mingw is broken on master (builds, but doesn't start), so I'm blocked on that one.
Comment 16 A (Andy) 2013-05-08 21:50:18 UTC
not reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

Does this issue still persist for you with the latest release of LO?
Comment 17 peter.hermsdorf 2013-05-13 06:58:54 UTC
tested with 4.0.3 under win7 pro 64-bit

not reproducible

we are on 3.6, but since there is no explicit patch it probably won't be fixed in a 3.x release?
Comment 18 QA Administrators 2015-03-04 02:20:06 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 19 Jean-Baptiste Faure 2015-03-06 05:13:18 UTC
Per comments #16 and #17 closing as WorksForMe.
Please, feel free to reopen if you disagree.

Best regards. JBF