Download it now!
Bug 44551 - libvisio: arrow head shapes not imported properly
Summary: libvisio: arrow head shapes not imported properly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-07 04:34 UTC by Bruno Girin
Modified: 2016-01-15 09:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Visio file that shows all possible arrow heads (40.00 KB, application/vnd.visio)
2012-01-07 04:34 UTC, Bruno Girin
Details
PNG output from Visio showing what the diagram should look like (40.51 KB, image/png)
2012-01-07 04:35 UTC, Bruno Girin
Details
PNG output from LibreOffice showing what LO imports (74.16 KB, image/png)
2012-01-07 04:36 UTC, Bruno Girin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Girin 2012-01-07 04:34:54 UTC
Created attachment 55251 [details]
Visio file that shows all possible arrow heads

When importing a Visio diagram that contains arrows, the arrow heads are not imported properly. Please see attached for an example file, as well as PNG exports both from Visio and LO.
Comment 1 Bruno Girin 2012-01-07 04:35:48 UTC
Created attachment 55252 [details]
PNG output from Visio showing what the diagram should look like
Comment 2 Bruno Girin 2012-01-07 04:36:28 UTC
Created attachment 55253 [details]
PNG output from LibreOffice showing what LO imports
Comment 3 Fridrich Strba 2012-01-11 02:46:01 UTC
The arrow heads are only initial implementation. Another entry-level task that could be done by someone trying to enter libvisio's world. The VSDXContentCollector::_lineProperties function is where all this is happening.
Comment 4 ign_christian 2013-06-14 12:57:55 UTC
It seems partially solved with LO 4.0.4.2 (Win7 32bit)
Comment 5 QA Administrators 2015-12-20 16:08:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 6 Fridrich Strba 2016-01-15 09:09:01 UTC
I am closing this but, since we already import a wide scale of arrow-heads and any other bug should be reported with a patch to fix it, since the implementation is really not a rocket-science.