Bug 44569 - Heavenetica5 font detected as a symbol, no spellchecking available
Summary: Heavenetica5 font detected as a symbol, no spellchecking available
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-08 03:00 UTC by Shankara
Modified: 2016-02-09 09:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Heavenetica5 font files (34.09 KB, application/x-font-ttf)
2012-01-08 03:07 UTC, Shankara
Details
First line is in 'Arial' and the second line is in Heavenetica5. Each line contains a spelling mistake at the end. Line typed in "Arial" font shows the error. (10.86 KB, application/vnd.oasis.opendocument.text)
2012-05-07 08:38 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shankara 2012-01-08 03:00:54 UTC
Respected Sir.
I try to explain our experience. Spell check is not working in "Heavenetica5" font , where as spell check works for other fonts like Arial. We do know is it a bug or a configuration problem. I don't know what are the relevant information to be given to help you solve the issue. Please contact me for what ever information you need.

Kindly help.  

Warmest regards and thanks in advance. 
Shankara
Comment 1 Shankara 2012-01-08 03:07:00 UTC
Created attachment 55282 [details]
Heavenetica5 font files

Sir, 
I have uploaded the font files which might help you to re create the same problem.

regards
shankara
Comment 2 sasha.libreoffice 2012-05-07 06:17:55 UTC
Thanks for bugreport
Please, attach document where is some correct text on Heavenetica5 font and on Arial font.
Comment 3 sasha.libreoffice 2012-05-07 08:38:01 UTC
Created attachment 61145 [details]
First line is in 'Arial' and the second line is in Heavenetica5. Each line contains a spelling mistake at the end. Line typed in "Arial" font shows the error.
Comment 4 sasha.libreoffice 2012-05-07 08:46:58 UTC
Thanks for attachment.
Sorry, can not reproduce problem. On my computer both lines spellchecked.

Try to move LibreOffice user profile (~/.config/libreoffice and ~/.libreoffice) in another place and verify if problem still exist.
Comment 5 Andras Timar 2012-09-17 19:34:17 UTC
I reproduced the problem on Windows XP with LibreOffice 3.6.1.2. No red wawe underlining in Heavenetica5 text and F7 spell check ignores spelling error in it, too. Important: the font has to be installed. Without it the spell checking works.
Comment 6 Urmas 2012-11-08 15:28:47 UTC
That font looks like a symbol one.
Comment 7 QA Administrators 2015-01-05 17:52:10 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 8 Buovjaga 2015-01-28 18:47:45 UTC
Reproduced.

Win 7 Pro 64-bit, LibO Version: 4.3.6.1
Build ID: 9629686a67dd1f357477c13325e45a66f3452bb9
Comment 9 Joel Madero 2015-07-04 15:18:45 UTC
I am relatively sure this is a property of the font and not a bug in LibreOffice - will try to investigate
Comment 10 Adolfo Jayme 2016-02-09 08:47:15 UTC
I agree with Joel in that it is a font issue. Please inform the font vendor about it. (For starters, that font is not even Unicode-encoded…)
Comment 11 Adolfo Jayme 2016-02-09 09:03:13 UTC
I guess I should expand on my previous comment. The buggy font’s glyphs are not encoded in the Latin-1 area (this page displays them in the Private Use Area [1]). And you probably won’t be able to contact the font’s vendor [2][3] since it is so old (apparently, it dates from 1993, thus explaining why the font isn’t Unicode-compliant).

[1] http://www.azfonts.net/load_font/heregsh_.html#font-characters
[2] http://luc.devroye.org/fonts-25335.html
[3] https://www.microsoft.com/typography/links/vendor.aspx?VID=SOHO

Since “Heavenetica” is just a Helvetica clone, and a very old one, you should use a more modern typeface instead and benefit from a properly-encoded document. Helvetica’s design is ubiquitous: it comes with OS X (Helvetica/Helvetica Neue), Windows 10 (Neue Haas Grotesk Text Pro), and Linux (FreeSans/Nimbus Sans).