Bug 44739 - FILEOPEN Binary format import: dates in year 1900 corrupted
Summary: FILEOPEN Binary format import: dates in year 1900 corrupted
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 10:36 UTC by Urmas
Modified: 2012-03-05 09:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-01-12 10:36:42 UTC
When opening Excel or Lotos-123 binary spreadsheets, the dates in 1900 become corrupted: 1900-01-01 becomes 1899-12-31, ... 1900-02-28 -> 1900-02-27, but 1900-03-01 and later are OK.

In EACH AND EVERY spreadsheet value "1" means 1900-01-01, and "60" -"- 1900-02-29.
Comment 1 wope 2012-03-04 10:14:15 UTC
Excel has an error. 1900 is NOT a leapyear, but MS Office belief this.Try"1900-02-28" +1. You see 1900-02-29.
Comment 2 Urmas 2012-03-05 05:09:01 UTC
1. Lotus-123 has no relation to MS Office.
2. If a table stores date, it should be read as it intended. Shifting values by 1 day is not intended.
Comment 3 wope 2012-03-05 09:16:25 UTC
what shall we to? MS Office is wrong, maybe Lotus also (I didn't know) Shall we say, 1900 is a leapyear?, or earth is a disc? To minimize the error from this erronous spreadsheets programs - only the dates between 1900-01-01 and 1900-02-28 have a difference - but to correct this,1900-02-29  is wrong. We can't change this.