Bug 44830 - FORMATTING: number formatting broken after loading a spreadsheet
Summary: FORMATTING: number formatting broken after loading a spreadsheet
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-16 06:38 UTC by ancow
Modified: 2016-06-18 16:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example spreadsheet created using the described steps (7.34 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-01-16 06:38 UTC, ancow
Details
Incorrect format at file open. (13.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-12 19:31 UTC, Alberto Ferreira
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ancow 2012-01-16 06:38:22 UTC
Created attachment 55637 [details]
Example spreadsheet created using the described steps

Problem description: 

Steps to reproduce:
1. Create a new spreadsheet.
2. Enter the numbers "1", "1.1", "1.11", "1.111" and "1.1111" into separate cells.
3. Select these cells and choose "#,###.00##" as format string.
4. Save the spreadsheet as a .ods and load it after closing it.

Current behavior:
The formatting string is changed to "#,###.0000" and the cells are formatted accordingly.

Expected behavior:
The loaded spreadsheet looks and behaves the same as when it was saved.

Platform (if different from the browser): 
Debian testing; 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0 Iceweasel/8.0
Comment 1 sasha.libreoffice 2012-05-08 04:45:26 UTC
reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit
# replaces to 0

changing version to 3.3.4 as most early reproducible
Comment 2 Alberto Ferreira 2014-11-12 19:31:59 UTC
Created attachment 109367 [details]
Incorrect format at file open.
Comment 3 Alberto Ferreira 2014-11-12 19:33:16 UTC
reproduced in 4.3.4.

The attach files repreduce the error.

Repeat the steps from  anncow
Comment 4 QA Administrators 2015-12-20 16:10:27 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 5 Laurent BP 2016-06-18 16:30:43 UTC
This has been fixed in LibO 5.0 with commit:
https://gerrit.libreoffice.org/14918/