Bug 44840 - VIEWING The bottom part of lines is clipped when proportional line spacing < 80%
Summary: VIEWING The bottom part of lines is clipped when proportional line spacing < 80%
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-16 12:59 UTC by V字龍(Vdragon)
Modified: 2015-06-07 10:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Bug example screenshot 1 (13.88 KB, image/png)
2012-01-16 12:59 UTC, V字龍(Vdragon)
Details
Example_document01 (16.45 KB, application/vnd.oasis.opendocument.text)
2012-01-17 04:21 UTC, V字龍(Vdragon)
Details
Bug example screenshot 2 (109.03 KB, image/jpeg)
2014-10-29 10:35 UTC, V字龍(Vdragon)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V字龍(Vdragon) 2012-01-16 12:59:48 UTC
Created attachment 55652 [details]
Bug example screenshot 1

下游bug報告網址:
Downstream bug report URL:
--------------------------
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/917367

軟體來源:
Software sources:
--------------------------
Ubuntu 11.10 repository

bug重現步驟:
bug reproducing steps:
--------------------------
1.「格式」→「段落」→「縮排與行距」→「行距」設定為「成比例、75%」。
  "Format"→"Paragraph"→"Indents & Spacing"→"Line spacing" set to "Proportional of 75%".
2.被套用此格式的多行應該要呈現成可以看到全部的字。
  On the screen, lines applied this format should be rendered as if their background is transparent and can see both lines.
  *This English Translation is not very clear*
3.如螢幕截圖所示部份的行被截掉沒有顯示(輸出結果不受影響)。
  As in the screenshot part of the line is clipped off and doesn't rendered to screen(it doesn't affect the (printer) output, though).
Comment 1 Christopher M. Penalver 2012-01-16 17:23:35 UTC
Henry Lin(林博仁), could you please attach the document in the screenshot to this bug?
Comment 2 V字龍(Vdragon) 2012-01-17 04:21:46 UTC
Created attachment 55670 [details]
Example_document01

Here you are.
The format only applied to the heading in that file(however in 3.4.4 it is easy to reproduce).
When it was initially opened it may rendered correctly, but if you scoll up and down part of the line will be clipped off.
Comment 3 V字龍(Vdragon) 2012-01-17 20:23:32 UTC
I assume that the information required is provided.
Please help yourself to change the status back if it is inappropriate. ;)
Comment 4 Christopher M. Penalver 2012-01-18 17:20:42 UTC
Reproducible in:
lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.5.0~beta2-2ubuntu3
  Candidate: 1:3.5.0~beta2-2ubuntu3
  Version table:
 *** 1:3.5.0~beta2-2ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

Openthe attachment→Select All→"Format"→"Paragraph"→"Indents & Spacing"→"Line spacing" set to "Proportional of 75%" and notice that some of the words are cropped horizontally at the bottom.
Comment 5 A (Andy) 2013-05-04 20:23:43 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 6 V字龍(Vdragon) 2014-10-29 10:08:24 UTC
Reproduced (again) in LibreOffice 4.3.2.2.
Comment 7 V字龍(Vdragon) 2014-10-29 10:35:26 UTC
Created attachment 108616 [details]
Bug example screenshot 2
Comment 8 Gordo 2015-06-07 10:11:06 UTC
Could not reproduce.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

4.3.6.2

Bug present in 4.2.8.2.

Changed to RESOLVED WORKSFORME.