Bug 45098 - Tables cannot be selected completly
Summary: Tables cannot be selected completly
Status: RESOLVED DUPLICATE of bug 43848
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 12:09 UTC by Carsten Niehaus
Modified: 2015-04-07 09:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File with defect tables (23.79 KB, application/vnd.oasis.opendocument.text)
2012-01-22 12:09 UTC, Carsten Niehaus
Details
Example 1: I tried to select ALL cells but missed a few (11.25 KB, image/png)
2012-01-22 12:10 UTC, Carsten Niehaus
Details
Example 2: I tried to select ALL cells but missed a few (10.05 KB, image/png)
2012-01-22 12:11 UTC, Carsten Niehaus
Details
Simplified version of the file (17.98 KB, application/vnd.oasis.opendocument.text)
2012-01-31 00:41 UTC, Carsten Niehaus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Niehaus 2012-01-22 12:09:39 UTC
Created attachment 55990 [details]
File with defect tables

Open the attaced file and try to select all cells of (for example) page 1. You won't be able to do so, the cells in the bottom left corner are left out. 

I also know why: There are "connected cells" (I don't know the correct english term, the german word is "Verknüpfte Zellen").

But still, this shouldn't happen. It is for example impossible to move the table of pages 1+2 somewhere else because you cannot select the complete table.


This is difficult to explain, thus I created to screenshots of the problem, I hope you can understand it better with those shots.
Comment 1 Carsten Niehaus 2012-01-22 12:10:56 UTC
Created attachment 55991 [details]
Example 1: I tried to select ALL cells but missed a few
Comment 2 Carsten Niehaus 2012-01-22 12:11:20 UTC
Created attachment 55992 [details]
Example 2: I tried to select ALL cells but missed a few
Comment 3 Carsten Niehaus 2012-01-22 12:12:45 UTC
I don't think this is related, but the file is the same as in bug 45097.
Comment 4 Carsten Niehaus 2012-01-31 00:38:45 UTC
confirmed with 

LibreOffice 3.5.0rc2 
Build-ID: e371a95-bf68a13-5a1aa2b-d3c1ae9-b938258
Comment 5 Carsten Niehaus 2012-01-31 00:41:37 UTC
Created attachment 56360 [details]
Simplified version of the file
Comment 6 Carsten Niehaus 2012-01-31 00:43:32 UTC
I just added a simplified version of the file. If you try to select all cells from the bottom right cell to the topmost left cell you will miss two the cells in the bottom left corner.

The only way to select all cells is to start in the bottom-left corner of the table and move to the top right corner.




LibreOffice 3.5.0rc2 
Build-ID: e371a95-bf68a13-5a1aa2b-d3c1ae9-b938258
Comment 7 tester8 2012-01-31 07:11:13 UTC
Reproduced with

LOdev 3.5.0rc2
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI

As described in comment 6.
Comment 8 Cor Nouws 2012-02-06 05:51:32 UTC
Hi Carsten,
Thanks for reorting and so.
I cannot download your test file (?? - same for bug 45097)
But I see the screen shots.
Is the problem also present in other verions of LibreOffice?
Comment 9 Carsten Niehaus 2012-02-07 01:37:12 UTC
The issue persists in rc3 of LO 3.5.0:


LibreOffice 3.5.0rc3 
Build-ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735




Funny, the attachement works here...
Comment 10 Carsten Niehaus 2013-03-08 19:11:06 UTC
Still valid with Version 3.6.5.2 (Build ID: 5b93205)
Comment 11 Cor Nouws 2015-01-15 21:07:41 UTC
Hi Carsten,

(In reply to Carsten Niehaus from comment #0)

> Open the attaced file and try to select all cells of (for example) page 1.
> You won't be able to do so, the cells in the bottom left corner are left
> out. 

Simply Ctrl+A when somewhere in table works for me in 4.3.5.2 on Ubuntu in all tables, except #6.

Tried to drag from bottom right to top and that indeed leaves bottom left unselected.

Is that the same for you?
And if so, we may consider to close as wontfix, since there is a good way to select the cells?
Comment 12 Matthew Francis 2015-04-07 09:39:33 UTC

*** This bug has been marked as a duplicate of bug 43848 ***