Bug Hunting Session
Bug 45122 - Opening WMF picture in writer/impress/draw causes 100%cpu load for a long time.
Summary: Opening WMF picture in writer/impress/draw causes 100%cpu load for a long time.
Status: RESOLVED DUPLICATE of bug 45820
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-01-23 04:53 UTC by Marco
Modified: 2016-09-24 20:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example WMF picture (715.74 KB, image/x-wmf)
2012-01-23 04:53 UTC, Marco
Details
Word document containing another WMF which makes LibO hang (705.50 KB, application/msword)
2012-12-17 19:34 UTC, cedrcaba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco 2012-01-23 04:53:31 UTC
Created attachment 56036 [details]
example WMF picture

Problem description: 
When you drag & drop attached WMF picture into Writer/Impress or Draw then it can take up to 40 seconds of 100% CPU load before the picture is shown.
When the document is saved and re-opened the time it takes to open it directly proportional to the number of WMF pictures used: ie with 5 example WMF pictures it will take 5 time as long (with 100% cpu load) as with one picture.

Steps to reproduce:
1. open new drawing or Text document or Presentation
2. drag & drop example WMF file into document
3. Watch high CPU load for long time with Task Manager.

Current behavior:
Adding WMF picture to document or opening document with WMF picture in it takes a very long time. LibreOffice appears to be locked up for that duration.

Expected behavior:
Expect to show the WMF picture immediately. Powerpoint shows presentation with multiple WMF pictures in it within seconds.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 1 tester8 2012-01-26 13:24:36 UTC
Reproduced with

LOdev 3.5.0rc1
e40af8c-10029e3-615e522-88673a2-727f724
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI
Comment 2 Marco 2012-12-17 09:00:34 UTC
I can confirm this bug on platform Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Comment 3 cedrcaba 2012-12-17 19:34:56 UTC
Created attachment 71683 [details]
Word document containing another WMF which makes LibO hang

.doc 97-2003
Comment 4 cedrcaba 2012-12-17 19:40:06 UTC
I can confirm this bug on LibreOffice 4.0.0.0 beta1 and with this another WMF picture.
Note that Apache OpenOffice 3.4 and OOO 3.3 can open these files normally, albeit some graphicals errors.
Comment 5 Marco 2013-01-21 13:47:03 UTC
I can confirm this bug on platform LO 4 RC1, Version 4.0.0.1 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)

See also bug 45820, is this a similar issue?
Comment 6 Marco 2013-08-05 14:29:42 UTC
This bug is still present on LibreOffice Version: 4.1.0.4 Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28. It takes about 40 seconds to open the attached example WMF file.

Note that Apache OpenOffice 4.0 opens this WMF file normally within a reasonable time, about 1 second.
Comment 7 QA Administrators 2015-04-19 03:21:02 UTC Comment hidden (obsolete)
Comment 8 cedrcaba 2015-05-05 19:43:10 UTC
Present in LibreOffice 4.4.3.2
Comment 9 Andras Timar 2015-06-27 17:01:49 UTC
Callgrind analysis showed that it is the same as bug 45820.

*** This bug has been marked as a duplicate of bug 45820 ***