Bug 45285 - Use more revealing error message for not allowed sheet names
Summary: Use more revealing error message for not allowed sheet names
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: Other All
: medium normal
Assignee: Albert Thuswaldner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 12:41 UTC by OfficeUser
Modified: 2012-01-31 11:36 UTC (History)
1 user (show)

See Also:


Attachments
MS Excel 2007 german.png (5.17 KB, image/png)
2012-01-26 12:41 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2012-01-26 12:41:51 UTC
Created attachment 56204 [details]
MS Excel 2007 german.png

Problem:

When trying to insert or rename a sheet with an already existing name, LibreOffice prints: "Invalid sheet name."

MS Excel uses more revealing error massage. Have a look at the attached screen shot (sorry it's german).

The current message "Invalid sheet name." gives the impression that a chosen sheet name is generally invalid. This is confusing if the document contains many sheets and it is recognizable immediately that the chosen name already exists.

Solution:
Use more revealing error message (like MS Excel) why sheet is not allowed.
Comment 1 Albert Thuswaldner 2012-01-26 13:01:42 UTC
I can have a go at this one. Should we add something like this?

Invalid sheet name. 

The following rules apply:
- cannot be a duplicate of an existing sheet name.
- cannot contain the characters [ ] * ? / \ .
- must be 31 or fewer characters.
Comment 2 OfficeUser 2012-01-27 08:18:46 UTC
It looks good!
Comment 3 OfficeUser 2012-01-30 14:14:05 UTC
Thanks for implementing. Will it be already fixed in 3.5 final?
Comment 4 Albert Thuswaldner 2012-01-31 11:36:15 UTC
(In reply to comment #3)
> Thanks for implementing. Will it be already fixed in 3.5 final?

No sorry it will not be in 3.5, you have to wait for 3.6 for this one. The reason is that 3.5 is in string freeze so that all the translators can keep up.

Hope you are not too down beat by this. Keep filing bugs if/when you find some and maybe help to resolve them, if you want. Your help is appreciated.