Bug Hunting Session
Bug 45287 - Adding too many pics to gallery makes Impress unresponsive
Summary: Adding too many pics to gallery makes Impress unresponsive
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86 (IA32) Windows (All)
: high minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 13:32 UTC by jareddabc
Modified: 2015-03-08 16:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jareddabc 2012-01-26 13:32:42 UTC
I wanted to add the OpenClipArt 2.0 file set to a new theme in the gallery.  The OpenClipArt 2.0 set contains about 26000 images in svg format.  I uncompressed the gallery into <LibreOffice home>/Basis/share/gallery/OpenClipArt-2.0/clipart.  I was able to get the file list using the Find Files... button in the theme properties.  However, upon adding about 100 files (either all at once or in sets), LO becomes unresponsive and must be forcibly killed.  The behavior is quite consistent, i.e. it does not vary from one trial to another.
Comment 1 Jorendc 2013-01-28 13:33:11 UTC
I can reproduce this behavior using LibreOffice 4.0.0.2 rc2 Version 4.0.0.2 (Build id: 408fe71bd18616c467b3dcd7ab6756528ffcae2) Linux Mint x64.

When I select an image (.png) it don't react at all. When I click on 'Search Files' and select a folder where I would like him to search into -> results in a full system scan (all folders are scanned). When clicking 'cancel' -> crash.

Following [1] I mark this bug as 'minor' 'high':
* minor: require user to not use some features
* high: because this is a more important bug in the 'minor' range I mark it as high (not default 'medium'). 

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Kind regards,
Joren
Comment 2 QA Administrators 2015-02-19 15:49:33 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 3 Buovjaga 2015-03-08 16:58:31 UTC
Installed openclipart-libreoffice 1:0.18+dfsg-14 from Ubuntu software center.

No problems in browsing Impress gallery afterwards.

Setting to WFM. Feel free to open back to NEW, if you still have the problem in 4.4.x.

Ubuntu 14.10 64-bit 
Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US