Bug 45288 - crash when opening Styles and Formatting
Summary: crash when opening Styles and Formatting
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
(earliest affected)
3.5.0 RC1
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
QA Contact:
Depends on:
Reported: 2012-01-26 14:59 UTC by Aljosha Papsch
Modified: 2012-07-07 22:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Aljosha Papsch 2012-01-26 14:59:57 UTC
Libreoffice crashes on GNU/Linux x86 when opening the window "Styles and Formatting" either with F11 or pressing the button in the tool bar.
I get the following message:

The program 'soffice' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 11705 error_code 8 request_code 42 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I compiled LibreOffice with debug support. When I start it with gdb and pass --sync as parameter, LibreOffice does not crash. I can't get a backtrace without --sync being passed. Breaking on gdk_x_error only presents me this question from gdb:

(gdb) b gdk_x_error
Function "gdk_x_error" not defined.
Make breakpoint pending on future shared library load? (y or [n])

Answering this with y doesn't help. GTK+ and GLib are compiled with debug symbols as well.
Comment 1 sasha.libreoffice 2012-05-11 03:26:00 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
Comment 2 Valek Filippov 2012-07-07 11:27:51 UTC
Cannot reproduce with LO

Aljosha, could you check if it's still reproducible on your system with in 3.5 release?
Comment 3 Rainer Bielefeld Retired 2012-07-07 22:00:19 UTC
Closing due to reporter's inactivity 

@Valek Filippov:
It a reporter did not answer within 7 weeks, it is improbable that he will now answer when you now ask the same answer again. Please consequently close such bugs with unsuccessful demand, it's nothing gut wasted time when various users from QA ask the same question again and again.

Please always add yourself to CC when you ask questions to reporter, so that you can proceed further steps if / when reporter answers.

@Aljosha Papsch:
Please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version and if you can contribute requested additional information due to <http://wiki.documentfoundation.org/BugReport> (especially BugReport Details)!