Bug 45371 - url corrupted when using the shift key to edit the cell
Summary: url corrupted when using the shift key to edit the cell
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
3.4.5 release
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2012-01-29 08:07 UTC by Jean-Baptiste Faure
Modified: 2017-02-01 05:51 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:

Still reproducable (5.16 KB, image/png)
2015-12-21 07:05 UTC, Luuk

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2012-01-29 08:07:58 UTC
Step to reproduce:
- open a new spreadsheet
- in a cell type an url, for example "http://something.com"
- click outside the cell -> the url is automatically transformed in an hyperlink
- select the cell and click in the formula bar
- add several characters *starting with a dot*, for example: ".test"
- validate

what happens : the hyperlink is changed in "httestt://something.com."

what is expected : the hyperlink is not corrupted.

An user (ubuntu 11.10) has the same problem if the url modification is done directly in the cell.
It seems that the bug does not affect KDE users, nor MS-Windows users.
No bug if automatic url recognition is disabled.

From my side I encounter this bug with LO 3.4.5 (ubuntu and vanilla versions) and LO 3.5.0 rc2+ (LibreOffice 3.5.0rc2+ Version ID : 20ec7c1-ed94322-5cd2479-2386a41-138191a)

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2012-01-29 09:45:35 UTC
Confirmed by several users on fr discuss list.
Not only gnome impacted, xfce (ArchLinux) too.

Best regards. JBF
Comment 2 vulcain 2013-02-03 22:23:34 UTC
Bug are still here with LibreOffice 3.5.7 or LibreOffice 4.0.0
I reproduce with OpenOffice 3.2.0
Comment 3 mohican 2013-02-05 11:57:44 UTC
from 3.5.3 the symptom has slightly changed :

now the hyperlink is not changed anymore, but it looses its hyperlink quality (i.e. reverts to standard text).
Comment 4 Markus Mohrhard 2013-02-20 21:22:17 UTC
If you can reproduce it with OpenOffice 3.2 then it is obviously not a regression in LibO.
Comment 5 mohican 2013-03-06 21:48:36 UTC
Again in LibreOffice I have the url corrupted by some part of the text being inserted inside it.

Apprently the bug appears when typing either a dot followed by some text, or an uppercase followed by some text.
Comment 6 QA Administrators 2013-09-24 02:01:26 UTC Comment hidden (obsolete)
Comment 7 Jean-Baptiste Faure 2013-09-25 15:10:34 UTC
Set status back to NEW because, as far as I understand correctly, there is no request for information in the last comments.

For the record: I just do the same steps as in my description with LO and I observed the same behavior. Same thing with the master (Version: Build ID: 079779c9244867cfcfb059ba57715af18b3a5bfc). Tested on Ubuntu 13.04 x86-64.

Best regards. JBF
Comment 8 Thomas Arnhold 2013-10-16 18:43:05 UTC
NOT reproducible on Windows 7 with

Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38

Build ID: 4badcfda55996891d99b1f0a8cc47028acd1c0c1

and NOT reproducible on ArchLinux with

Build ID: Arch Linux build-1

Build ID: 8aba9e76b6c6209b43a1b2a8e239f867ac63d08f
Comment 9 Thomas Arnhold 2013-10-16 18:44:22 UTC
I tried several cases:


And after that with and without a whitespace ".test". The link doesn't get corrupted for me. English locale.
Comment 10 mohican 2013-10-17 17:25:45 UTC
with LO under Ubuntu 12.04 LTS

I reproduce the bug exactly the way it is described. (Please note that you have to leave the cell after you entered the URL, and then come back to it.)

There is now only a problem when you add a texte that contains a dot or a capital letter in the formula bar.

- If the cell only contains the URL, as soon as you type the dot or capital letter the URL looses its property and the following letters starts inserting themselves in the midst of the URL.

- If the cell allready contains something more than the URL, after you add a dot or a capital letter, the URL looses its property but the following letters are not inserted inside the URL.
If you add the text directly in the cell (by double-clicking into the cell) there is no problem.
Comment 11 mohican 2013-10-17 17:27:04 UTC
LO french localization
Comment 12 mohican 2013-10-17 17:37:13 UTC
several other caracters will trigger the bug :
for example WITH FRENCH KEYBOARD : % ยง / ?
but some do not : , ; : !

In fact it seems that the bug is triggered by all caracters that need the SHIFT key to be used (except numbers).

So to test, try caracters that need the shift key to be pressed (they are not the same according to your keyboard localization).
Comment 13 Thomas Arnhold 2013-10-17 19:14:37 UTC
@mohican: Thanks! The SHIFT key is the difference. But pressing the SHIFT key the URL gets corrupted under Linux! So this is reproducible on Linux.

Still NOT reproducible on Windows!
Comment 14 Urmas 2013-10-18 00:50:37 UTC
I was able to reproduce it on Windows a couple of times, but I'm unsure how it was done exactly.
Comment 15 Thomas Arnhold 2013-10-18 06:24:58 UTC
Urmas, probably you tried to edit the link in the formula bar, see Bug 70597.

This bug here is about link corruption when inserting text, to separate it clearly.
Comment 16 Thomas Arnhold 2013-10-20 12:04:33 UTC
Ok, I finally reproduced this on Windows!

1. Type http://www.google.de/ into a cell
2. Leave the cell
3. Navigate into the cell with arrow keys

5. Press SHIFT - The URL will loose it's link attribute (the color will get white).

6. Type "aaa". The link will now look like "haaattp://www.google.de/" in the cell, but http://www.google.de/aaa" in the formula bar! The cursor is correctly positioned in the formula bar, but in the cell the cursor moved due to the SHIFT key event (to position 1).

This is reproducible on Windows and Linux.
Comment 17 mohican 2014-12-07 14:30:57 UTC
Still there on version

Now, what you type is no longer inserted inside the URL, but the URL looses its quality as an URL.
Comment 18 Luuk 2014-12-07 15:45:00 UTC
(In reply to Thomas Arnhold from comment #16)
> 5. Press SHIFT - The URL will loose it's link attribute (the color will get
> white).

This will ONLY happen when in the formulabar, NOT when typing in the cell.

Possible workaround:
Change the cell contents in the cell itself (and not in formulabar) ?
Comment 19 QA Administrators 2015-12-20 16:09:25 UTC Comment hidden (obsolete)
Comment 20 Luuk 2015-12-21 07:05:42 UTC
Created attachment 121462 [details]
Still reproducable

Bug is still there in LibreOffice (x64) on Windows 10
See https://bugs.documentfoundation.org/show_bug.cgi?id=45371#c16 for details on how to reproduce this.
Comment 21 QA Administrators 2017-01-03 19:55:35 UTC Comment hidden (obsolete)
Comment 22 Jean-Baptiste Faure 2017-02-01 05:51:16 UTC
Not reproducible anymore for me with LO under Ubuntu 16.04 x86-64.
To modify the hyperlink you now have to select the link and hit ctrl+K to open the hyperlink dialog. Adding a string at the end of the hyperlink does not change it.

Closing as WorksForMe.

Best regards. JBF