Bug 45453 - db no bool support => any query with "many" rows fails to open in datasheet
Summary: db no bool support => any query with "many" rows fails to open in datasheet
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86-64 (AMD64) Linux (All)
: highest major
Assignee: Lionel Elie Mamane
QA Contact:
URL:
Whiteboard: target:3.6.0 target:3.5.1 target:3.5.0
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-01-31 08:56 UTC by sasha.libreoffice
Modified: 2012-02-10 03:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-01-31 08:56:36 UTC
I have connected to Firebird using ODBC. Name of database is employee.fdb, password is masterkey, user is sysdba
This database installs with Firebird
LibreBase opened database, but when I attempt to execute this:
select * from "COUNTRY";
appears this error:
SQL Status: HY000
Error code: -206

[ODBC Firebird Driver][Firebird]Dynamic SQL Error
SQL error code = -206
Column unknown
TRUE
At line 1, column 33

some other information is given in this bug:
Bug 34432 - firebird ODBC: LibO crashes on 64 bits
Comment 1 sasha.libreoffice 2012-01-31 09:09:50 UTC
When I connected to this database using Flamerobin (exist in repository of Fedora, http://www.flamerobin.org), and executed this:
select * from "COUNTRY";
it executed successfully. 
Then I start interception by Fireshark and executed this statement by LibreBase:
First Librebase issued this 2 times:
select * from "COUNTRY" WHERE (0=1)
then this:
select * from "COUNTRY"
and finally this:
SELECT * FROM "COUNTRY" WHERE ( TRUE = ? AND "COUNTRY"."COUNTRY" = ? OR TRUE = ? AND "COUNTRY"."COUNTRY" IS NULL ) 

and Firebird return error:
Column unknown
TRUE
At line 1, column 33
Comment 3 Lionel Elie Mamane 2012-01-31 14:08:37 UTC
If the database system brea
Comment 4 Lionel Elie Mamane 2012-02-01 00:43:38 UTC
Reopening so that bug shows up as not fixed in 3.5 before it actually is.

Severity "blocker" as per definition "Blocks development and/or testing work": cannot further test compatibility with Firebird SQL.

This is not an opinion that it should block the release of 3.5.0
Comment 5 Lionel Elie Mamane 2012-02-01 01:52:18 UTC
Affected: sqlite3, Firebird

Not affected: MySQL, PostgreSQL, HSQLDB
Comment 6 Petr Mladek 2012-02-01 01:55:31 UTC
First, thanks a lot for fixing the bug. You do amazing job.

Just please do not use the "blocker" severity in this case. IMHO, it should be used only for bugs that really blocks the release. Almost any bug could block someones work if he really needs the functionality. On the other hand, many of the bugs are corner cases that affects only limited group of users or have reasonable workarounds. We would need to block the release few years if we would like to fix them all. AFAIK, this problem was there for ages and discovered recently. It means that nobody really needed it for ages. I am sorry but such bugs can't block the release. You actually agree with this :-)
Comment 7 Petr Mladek 2012-02-01 02:08:32 UTC
Ah, I was too fast. It is new core => new bug => regression.
I am still not convinced that it is a blocker but I will do my best to get it into 3.5.0. There is still chance.
Comment 8 Lionel Elie Mamane 2012-02-01 02:49:45 UTC
(In reply to comment #6)

> Just please do not use the "blocker" severity in this case. IMHO, it should be
> used only for bugs that really blocks the release.

Our "bug reporting" instructions at http://wiki.documentfoundation.org/BugReport_Details#Severity say *nothing* about "blocker" severity being linked in any way with "blocks the release" or even "particularly grave bug". It just says "blocks development/testing" *independently* of the gravity of the bug. As I understand what I read, even if the bug is otherwise "normal", if it "blocks development / testing", it is severity blocker.

Since then I've found http://wiki.documentfoundation.org/Release_Criteria which indeed seems to suggest that we use "blocker" severity for bugs that should block the release. Actually, I think that's sensible, but then the "BugReport Details" wiki page needs to say that, too. I just changed it so that it does.

If we exclude blocker, according to the definitions on "BugReport Details", this is definitely not "critical", but "major". Setting severity to "major".

Setting regression keyword as this breaks SQLite and Firebird which used to work (with 32 bit ODBC driver, and maybe JDBC driver for SQLite).

> I am sorry but such bugs can't block the release. You actually agree with this :-)

Yes, I do.

(And Sasha, I'm sorry we get into meta-discussion of our internal policies on your bug...)
Comment 9 Lionel Elie Mamane 2012-02-01 03:05:14 UTC
Now fixed in 3.5 branch (to become 3.5.1) and in 3.5.0 branch (to become 3.5.0rc3 and then 3.5.0).
Comment 10 sasha.libreoffice 2012-02-10 03:39:31 UTC
To be continued ...
Bug 45881 - Database: error when executing statment