Download it now!
Bug 45479 - Shape and location of autoshapes in a docx file is not reproduced
Summary: Shape and location of autoshapes in a docx file is not reproduced
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 RC2
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx
: 45480 (view as bug list)
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2012-01-31 23:13 UTC by Haruyuki Fujimaki
Modified: 2020-03-12 13:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample (18.02 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-01-31 23:13 UTC, Haruyuki Fujimaki
Details
Screenshot of the bug (475.53 KB, application/vnd.oasis.opendocument.presentation)
2012-01-31 23:26 UTC, Haruyuki Fujimaki
Details
test 2 (21.39 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-01-03 00:30 UTC, Ruslan Kabatsayev
Details
Test 2 - how it looks in LibO (67.17 KB, image/png)
2013-01-03 00:31 UTC, Ruslan Kabatsayev
Details
Test 2 - how it should look (115.26 KB, image/png)
2013-01-03 00:31 UTC, Ruslan Kabatsayev
Details
test 2 - how it looks in LibO 6.0.0.0.alpha1 (136.97 KB, image/png)
2017-12-08 09:36 UTC, Ruslan Kabatsayev
Details
Test Case : docx LO 6.0.0.3 arrows in diagram backwards (20.07 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-02-03 00:24 UTC, Philip Clarke
Details
How diagram arrows look in word (485.41 KB, image/png)
2018-02-03 00:27 UTC, Philip Clarke
Details
Example: arrows wrong way on docx import (295.39 KB, image/png)
2018-02-03 00:32 UTC, Philip Clarke
Details
test 2 compared MSO LO (201.04 KB, image/png)
2020-03-12 13:17 UTC, Timur
Details
Test Case 3 compared MSO LO (139.18 KB, image/png)
2020-03-12 13:36 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Haruyuki Fujimaki 2012-01-31 23:13:20 UTC
Created attachment 56423 [details]
Sample

Location of autoshape(speech balloon) in a docx file which was created with MS Word is not preserved at original place. Shape is also deformed.
Comment 1 Haruyuki Fujimaki 2012-01-31 23:26:41 UTC
Created attachment 56425 [details]
Screenshot of the bug
Comment 2 David Tardon 2012-02-01 22:22:27 UTC
*** Bug 45480 has been marked as a duplicate of this bug. ***
Comment 3 Ruslan Kabatsayev 2013-01-03 00:30:22 UTC
Created attachment 72406 [details]
test 2

The original test looks much better as of Version 4.1.0.0.alpha0+ (Build ID: ca3aba4cdf766cf33b0dbbe495c9e6f57f06982), still not identical to how it should look.
I attach another test, which is messed up much more.
Comment 4 Ruslan Kabatsayev 2013-01-03 00:31:20 UTC
Created attachment 72407 [details]
Test 2 - how it looks in LibO
Comment 5 Ruslan Kabatsayev 2013-01-03 00:31:43 UTC
Created attachment 72408 [details]
Test 2 - how it should look
Comment 6 Alexandr 2014-02-20 16:24:17 UTC
In the original test case the position is correct, I can see only bug 70942 (I tried in LibreOffice 4.1.4). The second case is corrupted even in LibreOffice 4.3.0.0.alpha0+
Build ID: 80d9fbdde2a921958ec6725a1d80ba17fc5165c9
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-02-18_07:47:01 on Debian x86_64. So, change platform to all.

According to my experience, the problem is common and makes schemes in docx unusable. That's why I think importance of the bug should be increased.
Comment 7 Alexandr 2015-05-24 11:44:16 UTC
In LibreOffice 5.0.0.0beta1 the original file looks correct, but the second one is still imported wrong way.
Comment 8 Robinson Tryon (qubit) 2015-12-13 12:18:24 UTC Comment hidden (obsolete)
Comment 9 Telesto 2016-12-07 14:10:31 UTC
First sample sames to be fine, but confirming test 2
Version: 5.4.0.0.alpha0+
Build ID: a9f56091b6422ec8c42f09b8472200ae4ab12548
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-05_23:12:26
Locale: nl-NL (nl_NL); Calc: CL
Comment 10 QA Administrators 2017-12-08 08:09:11 UTC Comment hidden (obsolete)
Comment 11 Ruslan Kabatsayev 2017-12-08 09:36:53 UTC
Created attachment 138300 [details]
test 2 - how it looks in LibO 6.0.0.0.alpha1

Here's how test 2 looks now. The arrows are almost there, but still not precisely enough. Simiarly for text labels. Tested on:

Version: 6.0.0.0.alpha1
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU threads: 4; OS: Linux 3.16; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 12 Philip Clarke 2018-02-03 00:24:27 UTC
Created attachment 139541 [details]
Test Case : docx LO 6.0.0.3 arrows in diagram backwards

Test docx document on Mac opened in LO 5.4.2 to 6.0.0.3 very simple labeled diagram has arrows pointing in the wrong direction and surrounding diagram border missing.
Comment 13 Philip Clarke 2018-02-03 00:27:10 UTC
Created attachment 139542 [details]
How diagram arrows look in word
Comment 14 Philip Clarke 2018-02-03 00:32:05 UTC
Created attachment 139543 [details]
Example: arrows wrong way on docx import

Libreoffice 6.0.0.3 on Mac, rulers included in screenshots, seems to be no differing fonts paper sizes or border.
Comment 15 QA Administrators 2019-02-19 03:42:56 UTC Comment hidden (obsolete)
Comment 16 Timur 2020-03-12 13:17:20 UTC
Created attachment 158651 [details]
test 2 compared MSO LO

As noted, 1st attachment 56423 [details] is OK.

Adding different sample test 2 was wrong, but when it's here: 
attachment 72406 [details] opens differently in MSO 2016 and LO 7.0+, but it's 2007 DOCX.
If resaved in MSO, it opens the same in MSO and LO as with previous LO.
It's one of the cases where MSO is not consistent, not LO.
Comment 17 Timur 2020-03-12 13:24:54 UTC
I'll close this bug for 1st and 2nd samples. 

Different 3rd example is still wrong, but that's another issue.
Comment 18 Timur 2020-03-12 13:36:06 UTC
Created attachment 158652 [details]
Test Case 3 compared MSO LO

Attachment 139541 [details] is mostly about arrows. 
I'll mention it in bug 100751.