Download it now!
Bug 45567 - EDITING: Undo does not undo math formula edits
Summary: EDITING: Undo does not undo math formula edits
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 14:35 UTC by gry
Modified: 2015-03-09 05:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gry 2012-02-02 14:35:50 UTC
STR:
 1) Insert a math equation, containing 'a^2 + b^2' 
 2) Exit math editing mode 
 3) Double click the equation, type '= c^2' 
 4) Exit math editing mode 
 5) Click undo

Expected results:
 Equation containing 'a^2+b^2'

Actual results: 
 Writer sets focus to the equation, but it still shows 'a^2+b^2=c^2'
Comment 1 tester8 2012-02-03 02:01:05 UTC
Reproduced with

LibreOffice 3.5.0rc3
7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Ubuntu 10.04.3 x86
Linux 2.6.32-38-generic Russian UI

I am pretty sure that this is duplicate, but can't find original.
Comment 2 A (Andy) 2013-05-02 19:31:08 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 3 QA Administrators 2015-03-04 02:18:18 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 4 Jean-Baptiste Faure 2015-03-09 05:28:17 UTC
Not a bug for me. Formula is another document inside the text document. The undo/redo works in the formula editor.

Closing as NotABug. Please feel free to reopen if you disagree.

Best regards. JBF