Bug 45584 - SLIDESHOW: view incomplete with hardware acceleration.
Summary: SLIDESHOW: view incomplete with hardware acceleration.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard: target:3.6.0 target:3.5.1
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-02-03 03:38 UTC by Florian Effenberger
Modified: 2012-04-04 09:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Slide deck (655.93 KB, application/vnd.oasis.opendocument.presentation)
2012-02-03 03:39 UTC, Florian Effenberger
Details
Screenshot (143.47 KB, image/png)
2012-02-03 03:40 UTC, Florian Effenberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Effenberger 2012-02-03 03:38:47 UTC
Playing the attached presentation, created with 3.4, on 3.5 Mac leads to a defective view, see atttached screenshot. Seems to be a Mac-only problem so far.
Comment 1 Florian Effenberger 2012-02-03 03:39:51 UTC
Created attachment 56567 [details]
Slide deck
Comment 2 Florian Effenberger 2012-02-03 03:40:54 UTC
Created attachment 56568 [details]
Screenshot
Comment 3 Mike §chinagl 2012-02-03 04:12:21 UTC
I looked at the slide deck under Windows XP and can see it flawlessly, so apparently the file is not corrupted in any way. Without a Mac I cannot confirm the bug though.
Comment 4 Petr Mladek 2012-02-03 05:09:33 UTC
I am unable to reproduce this on Linux with LO-3.5.0-rc3 build.

Anyway, the screenshot speaks clearly that most of the slide is not shown on Florian's system.

Adding some Impress experts into CC. Thorsten is even capable to debug on MAC.
Comment 5 Thorsten Behrens (CIB) 2012-02-03 05:16:58 UTC
Damn. Will check, but prolly only after fosdem
Comment 6 Florian Effenberger 2012-02-04 01:34:28 UTC
Disabling hardware acceleration seems to cure the problem, but IMHO it's a bug
Comment 7 Alex Thurgood 2012-02-05 04:03:33 UTC
Confirming on Mac OSX 10.6.8 (Snow Leopard)

The presentation is incorrectly displayed with "Hardware acceleration" option activated.

Deactivating "Hardware acceleration" allows the presentation to be displayed correctly.


Alex
Comment 8 Alex Thurgood 2012-02-05 04:04:34 UTC
(In reply to comment #7)


Some kind of overlay problem of the graphical objects ??

Alex
Comment 9 Thorsten Behrens (CIB) 2012-02-17 07:36:36 UTC
Cairocanvas is the culprit, which was never used in production for Mac. Disable again for 3.5.1
Comment 10 Thorsten Behrens (CIB) 2012-02-17 07:37:27 UTC
Note to self (and rodo) - looks like a resource exhaustion, does only happen for complex slides.
Comment 11 Not Assigned 2012-02-17 07:38:11 UTC
Thorsten Behrens commited a patch related to this issue to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fdfeb21102e85f94a1ecb22fb376e1875319765e

Fix fdo#45584 - disable cairocanvas on Mac.
Comment 12 Not Assigned 2012-02-17 08:35:32 UTC
Thorsten Behrens commited a patch related to this issue to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b42475b8e64ec16d86b103dd0356a3cf5a836b0&g=libreoffice-3-5

Fix fdo#45584 - disable cairocanvas on Mac.


It will be available in LibreOffice 3.5.1.
Comment 13 Rainer Bielefeld Retired 2012-04-04 09:57:02 UTC
@All: 
Please use meaningful Summary lines!