Bug Hunting Session
Bug 45680 - [Calc] [AutoFilter] Inconsistent formats in the box of the filter
Summary: [Calc] [AutoFilter] Inconsistent formats in the box of the filter
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:3.6
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-06 02:44 UTC by Michel Rudelle
Modified: 2016-02-21 16:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
spreadsheet containing timestamp values displayed with a date format (146.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-02-06 02:44 UTC, Michel Rudelle
Details
screenshot of the filter box (20.60 KB, image/jpeg)
2012-02-13 12:24 UTC, Michel Rudelle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Rudelle 2012-02-06 02:44:46 UTC
Created attachment 56653 [details]
spreadsheet containing timestamp values displayed with a date format

Hi,
When filtering on timestamp displayed with a date format, the box of the filter shows some values in the timestamp format instead of the date format.
This prevents from selecting the whole day.

See the joined example
LibO 3.5.0 rc3 / Windows 7
(tested on 3.4.5: no problem)
Comment 1 Jean-Baptiste Faure 2012-02-12 10:47:17 UTC
Indeed, the filter box shows the value without format while the filter works on formatted values.
Confirmed with LO 3.5.0 rc3 and LO 3.5.1rc0+ (Version ID : 848b0b4-8c0b455-f9b8d0b-ad1896d-24eb504)

Kohei: it seems that this one is for you. Please feel free to reassign if you can't handle this.

Best regards. JBF
Comment 2 Michel Rudelle 2012-02-13 12:24:21 UTC
Created attachment 56988 [details]
screenshot of the filter box
Comment 3 Michel Rudelle 2012-02-13 12:25:43 UTC
Here are additional explanations:
I use frequently the autofilter on a column of timestamp formated in dates, what allows me to select quickly a whole day. With the joined spreadsheet file, while all the column indeed has the same format, the box of the filter gives the result shown in the joined screenshot.
For instance, I cannot in this example select the date of 08/01/2010 and obtain all the data of this day, I can only select a single line while this day contains 11 lines.
That works correctly on previous versions (3.4)
Comment 4 A (Andy) 2015-02-07 22:03:39 UTC
I tested it with LO 4.4.0.3, Win 8.1 and in my case it looks different.  LO recognises the date format and shows the year, months and days which I can then select.  Was there maybe a change in LO since this bug was reported?
Comment 5 QA Administrators 2016-02-21 08:37:14 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice 
   (5.0.5 or 5.1.0)  https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and 
   your operating system, and any changes you see in the bug behavior
 
   If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
   a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
   appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-02-21
Comment 6 Jean-Baptiste Faure 2016-02-21 16:40:01 UTC
(In reply to A (Andy) from comment #4)
> I tested it with LO 4.4.0.3, Win 8.1 and in my case it looks different.  LO
> recognises the date format and shows the year, months and days which I can
> then select.  Was there maybe a change in LO since this bug was reported?

Same for me with LO 5.1.2.0.0+
Closing as WorksForMe. Feel free to reopen if you disagree.

Best regards. JBF