Download it now!
Bug 45845 - SVG rendering regression in Draw and Impress (LibreOffice 3.4.4 and above)
Summary: SVG rendering regression in Draw and Impress (LibreOffice 3.4.4 and above)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-02-09 08:29 UTC by Roland Baudin
Modified: 2016-05-01 16:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test archive with odg, svg files and screenshots (228.90 KB, application/zip)
2012-02-09 08:29 UTC, Roland Baudin
Details
Screenshot of LibreOffice Draw 3.5.1 (41.26 KB, image/png)
2012-03-19 09:21 UTC, Roland Baudin
Details
shows how the bug manifests in Impress and Draw but not Writer (69.70 KB, application/x-gzip)
2012-09-19 17:03 UTC, rfvuhbtg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Baudin 2012-02-09 08:29:06 UTC
Created attachment 56823 [details]
Test archive with odg, svg files and screenshots

There is a regression in the way SVG graphics are rendered in LibreOffice 3.4.4 Draw and Impress components.

Opening or inserting SVG files in Draw and Impress renders curves or straight lines as thick blurry lines. Note that Writer is not affected.

To reproduce : open the files figures.svg and equation.svg from the attached test archive in Draw, or insert them in an empty Draw or Impress document and look at the results.

This worked OK in LibreOffice 3.4.3, so this is a regression, as you can see in the attached screenshots.
Comment 1 Jean-Baptiste Faure 2012-03-17 10:51:02 UTC
Hi Roland,

Please, could you try again with LO 3.5.1 ? It seems to work as expected.

Best regards. JBF
Comment 2 Roland Baudin 2012-03-19 09:21:25 UTC
Created attachment 58695 [details]
Screenshot of LibreOffice Draw 3.5.1

Hi,
the bug is half fixed: as you can see in the attached screenshot (done with Libo 3.5.1) inserting a svg file works now as expected, but opening an svg file still does not work correctly.

Since the bug appeared in version 3.4.4, perhaps it could be found from the analysis of what changed between 3.4.3 and 3.4.4.

Best regards,
RB
Comment 3 Manfred Kitzbichler 2012-06-04 18:01:09 UTC
I just updated my LibreOffice from 3.4.5 to 3.5.3 and I am now seeing the same problem with the LaTeX equation plugin "TexMaths". This seems to occur only in impress and draw, but not in writer. Also when I go to presentation mode with F5 the equations seem to render fine. I did not use TexMaths with LibreOffice 3.4.5 but its predecessor OOOLatex, so there is a chance the bug existed before. Alternatively there might also be a problem with TexMaths, with the SVG equations it produces. But the fact that rendering in writer and in presentation mode seems fine points towards a bug in LibreOffice.
Comment 4 Manfred Kitzbichler 2012-07-31 22:04:08 UTC
Still the same bug in LibreOffice 3.5.4.7 from the latest OpenSuse update.

Would be great if somebody could dedicate some time to fix this extremely annoying regression.
Comment 5 Jean-Baptiste Faure 2012-08-01 05:15:01 UTC
Please, do not change version number, it indicates the first version in which the bug has been found. Set back to 3.4.4
Comment 6 rfvuhbtg 2012-09-11 16:23:09 UTC
Any chance that this bug might get fixed soon?  It's been around for several versions, and has so far prevented me from recommending LibreOffice for technical presentations.

For example, TexMaths equations look ok when viewed as a Slideshow, but when just looking at the slides in normal interface, they look like garbage.  It looks really unprofessional when giving a talk somewhere, so for now I have to advise people to use Powerpoint.  That just means more .pptx files out there with frequent compatibility problems (with both LibreOffice and other versions of Powerpoint) and less ODF files around that we can rely on to actually look the same on two different computers.
Comment 7 Jean-Baptiste Faure 2012-09-11 19:08:32 UTC
(In reply to comment #6)
> Any chance that this bug might get fixed soon?  It's been around for several
> versions, and has so far prevented me from recommending LibreOffice for
> technical presentations.
> 
Hmmm, what can you do to help to fix this bug ?
Comment 8 Roland Baudin 2012-09-12 18:42:03 UTC
This bug was introduced between versions 3.4.3 and 3.4.4, so maybe it is simply a matter of looking at the diff file between these versions and finding the parts related to the SVG feature?
RB
Comment 9 rfvuhbtg 2012-09-19 17:03:53 UTC
Created attachment 67408 [details]
shows how the bug manifests in Impress and Draw but not Writer
Comment 10 rfvuhbtg 2012-09-19 17:05:38 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Any chance that this bug might get fixed soon?  It's been around for several
> > versions, and has so far prevented me from recommending LibreOffice for
> > technical presentations.
> > 
> Hmmm, what can you do to help to fix this bug ?

At the moment, I'm working on a graduate degree, so not much.  We'll see after
I graduate.

Anyway, I've packaged an .odp, an .odg and a .odt file to show the difference
in how the bug appears.  Namely, it only shows up in Impress and Draw, but not
Writer. And it appeared somewhere in the change from 3.4.3 to 3.4.4.

This is using TexMaths version 0.36, by the way.

By the way, what's the best way to get the source code from both of those
releases?  I checked the page at:
http://download.documentfoundation.org/libreoffice/src/
but that page stops at 3.4.5.
Comment 11 Roland Baudin 2012-10-08 11:37:03 UTC
The bug is still there in LibreOffice 3.6.2.2 (in Impress and Draw).
RB
Comment 12 Jean-Baptiste Faure 2012-10-09 04:43:32 UTC
Please reread comment #5
Comment 13 Roland Baudin 2012-10-09 06:38:27 UTC
Oops, sorry...
RB
Comment 14 rfvuhbtg 2013-02-07 18:31:36 UTC
Ok, don't ask me how, but I think the bold rendering bug that happens when using TeXMaths in Impress slide show view (and Draw) was fixed somehow in LibreOffice 4.0.

I just downloaded 4.0 and tested out my demonstration files (third attachment in this report), and the bolding issue no longer appears...

I think it's fixed now, somehow.
Comment 15 Roland Baudin 2013-02-09 13:23:33 UTC
Yes, I tested version 4.0 under Debian Squeeze and I don't see the bug anymore.
I think the bug can be closed now.
RB
Comment 16 Jean-Baptiste Faure 2013-09-29 17:13:35 UTC
Not reproducible anymore in LO 4.0.5 and 4.1.x.

Closing as WorkForMe because we do not know which commit fixed the issue.

Best regards. JBF
Comment 17 Jean-Baptiste Faure 2016-05-01 16:20:10 UTC
regression keyword set from description (it worked in 3.4.3).