Bug Hunting Session
Bug 45863 - EDITING: Custom Glue Points in group object not visible in 'Edit Glue Points' mode
Summary: EDITING: Custom Glue Points in group object not visible in 'Edit Glue Points'...
Status: RESOLVED DUPLICATE of bug 76277
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Connectors
  Show dependency treegraph
 
Reported: 2012-02-09 16:27 UTC by Daniel Espinosa
Modified: 2016-05-03 15:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document for tests (11.20 KB, application/vnd.oasis.opendocument.graphics)
2013-02-24 16:36 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Espinosa 2012-02-09 16:27:09 UTC
When you create a Group and add Glue Points to it, is not possible to see where they were added making difficult to others (or your self) to edit Glues in future editions.

If Glue Points button is pressed you must be able to see Glues added, then you can Move them.
Comment 1 sasha.libreoffice 2012-05-16 04:27:13 UTC
Thanks for bugreport
reproduced in 3.5.3 on Fedora 64 bit
Impossible to add glue points to group. And Glue points UI shows that possible add glue points to objects inside of group. But no glue points added.
Comment 2 Rainer Bielefeld Retired 2013-02-24 16:35:03 UTC
[Reproducible] with Server Installation of "LibO  4.0.1.1+   -  German UI / German Locale  [Build ID: 2c0c17a6e4bee0ee28131ea4bdc47edc700d659)]"  {tinderbox: @6, pull time  2013-02-1920:00(?)} on German WIN7 Home Premium (64bit) with newly created user profile ….\LODev\4\:

Steps how to reproduce:
1. open attached sample document
2. Select 'Connector' from Draw Toolbar. 
3. Start Connector line 5cm below top 2 rectangles group and approach to
   bottom line near red line, try to connect: 
   > You will find many points to snap the connector
4. Click 'Edit Glue Points' 
   Expected: Custom Glue points should become visible as in yellow rectangel below
   Actual: no Custom Glue points visible in group object
5. If necessary make visible Glue Points Toolbar and add some Custom Glue points
   Nearby bottom border of blue rectangle
   Expected: additional Custom Glue Points visible
   Actual: CGP becomes invisible when you insert next 
6. Try similar to steps 1-3
   You see that th CGPs have been inserted, the problem really is that they
   are invisible.

That is already broken since OOo 2.0, so inherited from OOo

@Radek:
Please change  Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 3 Rainer Bielefeld Retired 2013-02-24 16:36:03 UTC
Created attachment 75450 [details]
Sample Document for tests

See Comment above how to use
Comment 4 Rainer Bielefeld Retired 2013-02-24 16:50:44 UTC
There is a AOOo "Issue#61439 - Custom gluepoints not settable on group objects". But I believe they are wrong. It always was possible to add the glue points, but the bug in this report made the Glue points invisible.
Comment 5 QA Administrators 2015-02-19 15:45:26 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 6 Buovjaga 2015-03-08 19:09:49 UTC
(In reply to Rainer Bielefeld Retired from comment #2)
> Steps how to reproduce:
> 1. open attached sample document
> 2. Select 'Connector' from Draw Toolbar. 
> 3. Start Connector line 5cm below top 2 rectangles group and approach to
>    bottom line near red line, try to connect: 
>    > You will find many points to snap the connector
> 4. Click 'Edit Glue Points' 
>    Expected: Custom Glue points should become visible as in yellow rectangel
> below
>    Actual: no Custom Glue points visible in group object
> 5. If necessary make visible Glue Points Toolbar and add some Custom Glue
> points
>    Nearby bottom border of blue rectangle
>    Expected: additional Custom Glue Points visible
>    Actual: CGP becomes invisible when you insert next 
> 6. Try similar to steps 1-3
>    You see that th CGPs have been inserted, the problem really is that they
>    are invisible.

Reproduced.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 7 tommy27 2016-04-16 07:25:14 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 8 Heiko Tietze 2016-05-03 15:13:35 UTC
The glue points in the rectangle of the attached document that is not grouped can be accessed and modified easily. 

Closing this as DUPLICATE of #76277 because you want to access glue points within a group (upper rectangle). Feel free to reopen if I'm wrong.

*** This bug has been marked as a duplicate of bug 76277 ***