Bug 45874 - Function "show comments" is always enabled.
Summary: Function "show comments" is always enabled.
Status: RESOLVED DUPLICATE of bug 46278
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
QA Contact:
Keywords: regression
: 47753 47904 (view as bug list)
Depends on:
Reported: 2012-02-10 01:46 UTC by seb
Modified: 2012-10-03 08:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:

Function "show comments" is always enabled (8.52 KB, image/png)
2012-02-10 01:46 UTC, seb
sample document (23.30 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-06-02 12:29 UTC, seb

Note You need to log in before you can comment on or make changes to this bug.
Description seb 2012-02-10 01:46:16 UTC
Created attachment 56854 [details]
Function "show comments" is always enabled

When i open xlsx spreadsheet with comments in cells, function "show comments" is always enabled (see in screenshot). Please fix it.
Comment 1 Ángel Luis García García 2012-04-24 01:06:56 UTC
[Reproducible] with "LibreOffice - Windows XP SP3 (32bit) Spanish UI"
Comment 2 sasha.libreoffice 2012-05-17 05:03:28 UTC
Thanks for bugreport
Please, attach sample xlsx document that demonstrates this problem
Comment 3 seb 2012-06-02 12:29:23 UTC
Created attachment 62430 [details]
sample document

Here you are and sorry for the delay.
Comment 4 seb 2012-06-02 12:32:23 UTC
and sorry for my english ;)
Comment 5 sasha.libreoffice 2012-06-04 00:09:06 UTC
Thanks for attachment
reproduced in 3.5.0 beta 3 on Windows XP and 3.5.4 on Fedora 64 bit
NOT reproduced in 3.3.4 and 3.4.2, therefore regression
Comment 6 Martin 2012-06-29 03:22:35 UTC
This bug reports the same problem:

Bug 47904 - FILEOPEN MS2007 .xlsx shows comments what should be hidden
Comment 7 Noel Power 2012-08-09 14:39:03 UTC
*** Bug 47904 has been marked as a duplicate of this bug. ***
Comment 8 Noel Power 2012-08-09 14:42:08 UTC
*** Bug 47753 has been marked as a duplicate of this bug. ***
Comment 9 Noel Power 2012-08-09 14:47:51 UTC
seems fixed on master with with http://cgit.freedesktop.org/libreoffice/core/commit/?id=56b0b2cbc0dc6538617e3f3b1005e4723ca227b0
Comment 10 Michael Meeks 2012-10-03 08:37:01 UTC
Really a duplicate of bug#46278 that has a better commit trail. Fix will be in 3.6.3.

Thanks ! :-)

*** This bug has been marked as a duplicate of bug 46278 ***