Bug 46001 - : Usability: Numeric Keyboard <Enter> for OK Buttons
Summary: : Usability: Numeric Keyboard <Enter> for OK Buttons
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-13 08:44 UTC by Anastasius
Modified: 2017-08-26 17:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anastasius 2012-02-13 08:44:45 UTC
Problem description:

For some menus, the Enter button on the numeric keypad is ignored, but it should have the same effect as <Return> and the OK button.

Steps to reproduce:
1. Copy text from some other window (Firefox, ...)
2. New Text Document
3. Edit>Paste special
4. select 'unformatted text' by up/down arrows
5. press <Enter> on numeric keypad

Current behavior: nothing

Expected behavior: dialog should close and text be pasted

Same for the 'Format>Character' Dialog, and probably other dialogs. 'Format>Paragraph' is ok.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Same for OS X 10.4.11

Previously posted incorrectly as https://bugs.freedesktop.org/show_bug.cgi?id=45507
Comment 1 sasha.libreoffice 2012-05-17 07:45:09 UTC
Thanks for bugreport
not reproducible in 3.5.3 on Fedora 64 bit. Changing platform to MacOS X
Comment 2 Uwe Altmann 2012-10-08 17:57:53 UTC
<ENTER> on a Mac is expected to work most of the time same as <RETURN>. But not when using LO - here <ENTER> just does nothing when it comes to <OK>-buttons in dialog boxes. 
Expected: <ENTER> has over all and especially in dialog boxes the same effect as <RETURN>. 

(FYI: There is one Exception: In Writer when typing Text, <ENTER> generates a line feed whereas <RETURN> generates a return. This is already so, so there is no need to change something regarding the text editing behavior.)
Comment 3 QA Administrators 2015-12-20 16:14:30 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-01-03 19:48:56 UTC Comment hidden (obsolete)
Comment 5 eisa01 2017-08-26 17:42:46 UTC
Works for me in the paste special dialog using both return and fn-return (corresponding to enter: https://apple.stackexchange.com/questions/47565/return-vs-enter)

I tested in 3.3 as well to make sure the behaviour had changed. Then fn-enter did not work

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group