Bug Hunting Session
Bug 46026 - Command line converter + Conversion issues/inconsistencies between odt->doc, docx, pdf
Summary: Command line converter + Conversion issues/inconsistencies between odt->doc, ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: MultipleBugs
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 02:00 UTC by Jambunathan K
Modified: 2015-06-15 10:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice-bugs.org (573 bytes, text/x-org)
2012-02-14 02:00 UTC, Jambunathan K
Details
libreoffice-bugs.odt (20.52 KB, application/vnd.oasis.opendocument.text)
2012-02-14 02:01 UTC, Jambunathan K
Details
libreoffice-bugs.docx (17.76 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-02-14 02:02 UTC, Jambunathan K
Details
libreoffice-bugs.doc (29.50 KB, application/msword)
2012-02-14 02:03 UTC, Jambunathan K
Details
libreoffice-bugs.pdf (63.00 KB, application/pdf)
2012-02-14 02:04 UTC, Jambunathan K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jambunathan K 2012-02-14 02:00:12 UTC
Created attachment 57020 [details]
libreoffice-bugs.org
Comment 1 Jambunathan K 2012-02-14 02:01:43 UTC
Created attachment 57021 [details]
libreoffice-bugs.odt
Comment 2 Jambunathan K 2012-02-14 02:02:44 UTC
Created attachment 57023 [details]
libreoffice-bugs.docx
Comment 3 Jambunathan K 2012-02-14 02:03:34 UTC
Created attachment 57024 [details]
libreoffice-bugs.doc
Comment 4 Jambunathan K 2012-02-14 02:04:27 UTC
Created attachment 57025 [details]
libreoffice-bugs.pdf
Comment 5 Jambunathan K 2012-02-14 02:29:33 UTC
                              *scratch*
                              =========

Author: Jambunathan K <kjambunathan@gmail.com>
Date: 2012-02-14 Tue

Table of Contents
=================
1 Summary
2 Version information
3 Details of the attachment and the issues there of
    3.1 libreoffice-bugs.org
    3.2 libreoffice-bugs.odt
        3.2.1 Issues with ODT file
    3.3 libreoffice-bugs.pdf
        3.3.1 Issues with PDF file
    3.4 libreoffice-bugs.doc
        3.4.1 Issues with DOC file
    3.5 libreoffice-bugs.docx
        3.5.1 Issues with DOCX export


1 Summary 
----------

  Various issues with converting from an odt file to other formats
  using the LibreOffice command-line option "--convert-to".

2 Version information 
----------------------
  Tested with LibreOffice 3.4.5 OOO340m1 (Build:502) Windows build.

3 Details of the attachment and the issues there of 
----------------------------------------------------

3.1 libreoffice-bugs.org 
=========================
   
   Input file in Emacs/Orgmode format. See
   [http://orgmode.org/]. Attached for my own reference.
   

3.2 libreoffice-bugs.odt 
=========================

   ODT file created by the Emacs/Orgmode exporter. See
   [http://orgmode.org/manual/index.html] and
   [http://orgmode.org/manual/OpenDocument-Text-export.html#OpenDocument-Text-export].

   This file used as the input file for all the conversion operation
   listed below.

3.2.1 Issues with ODT file 
~~~~~~~~~~~~~~~~~~~~~~~~~~~

    The data-style-name option is not honored. Irrespective of what
    style name I choose, the date is rendered the same way -
    "14/02/12" - in the GUI.



  <text:date style:data-style-name="N75" 
             text:date-value="2012-02-14T00:00:00+05:30">
    14 Feb 2012
  </text:date>


3.3 libreoffice-bugs.pdf 
=========================

   Command used to produce this pdf file.

   Executing soffice --headless --convert-to pdf --outdir tests/ tests/libreoffice-bugs.odt
   convert tests\libreoffice-bugs.odt -> tests\libreoffice-bugs.pdf
   using writer_pdf_Export

3.3.1 Issues with PDF file 
~~~~~~~~~~~~~~~~~~~~~~~~~~~
    None. Looks good.

3.4 libreoffice-bugs.doc 
=========================

   Executing soffice --headless --convert-to doc --outdir tests/ tests/libreoffice-bugs.odt
   convert tests\libreoffice-bugs.odt -> tests\libreoffice-bugs.doc using MS Word 97

3.4.1 Issues with DOC file 
~~~~~~~~~~~~~~~~~~~~~~~~~~~

    - TOC levels are not preserved. The doc file shows only the
      top-level headings in the TOC. This is an inconsistency.
    

3.5 libreoffice-bugs.docx 
==========================

   Executing soffice --headless --convert-to docx --outdir tests/ tests/libreoffice-bugs.odt
   convert tests\libreoffice-bugs.odt -> tests\libreoffice-bugs.docx using Office Open XML Text

3.5.1 Issues with DOCX export 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    1. Author field is getting clobbered. It reads as below:

                   "AUTHOR DocInformation:Created"

    2. The embedded image is stripped from the output. This is a
       serious bug.
Comment 6 Jambunathan K 2012-02-14 02:31:03 UTC
The files doc and docx file were opened within LibreOffice. I *do not* have a Microsoft Office suite installed on my machine.
Comment 7 sasha.libreoffice 2012-03-21 08:53:10 UTC
Thanks for bugreport
I agree that problem with command line conversion exist. We have some another bugreport, describing this problem. They not fixed yet.
Comment 8 Roman Eisele 2012-05-07 09:21:50 UTC
Compare Bug 40186 - "Command-line conversion from HTML produces HTML, not RTF, DOC, etc."
Comment 9 Shai Petel 2013-07-17 16:39:06 UTC
Similar issue perhaps, i reported: #67005
Attached a docx file that in export to PDF via command prompt the TOC is completely missing.

When doing the same using UI it produces a clean PDF.

The sample file is attached to that issue, for those who do not have MS office to reproduce.

Thanks!
Comment 10 Robinson Tryon (qubit) 2013-11-25 01:47:11 UTC
Looks like multiple bugs in one report -- please try to keep issues simple and targeted so it's easy for us to reproduce and hand-off to a developer.

I'm just going to choose one of the listed issues...

(In reply to comment #5)
>
> 3.5 libreoffice-bugs.docx 
> ==========================
> 
>    Executing soffice --headless --convert-to docx --outdir tests/
> tests/libreoffice-bugs.odt
>    convert tests\libreoffice-bugs.odt -> tests\libreoffice-bugs.docx using
> Office Open XML Text

I'm testing with LO Version: 4.2.0.0.beta1 + Ubuntu 12.04.3

> 
> 3.5.1 Issues with DOCX export 
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> 
>     1. Author field is getting clobbered. It reads as below:
> 
>                    "AUTHOR DocInformation:Created"

Possible Repro:

The Author line in the original ODT appears as "Jambunathan K". In the docx output, the line appears as "AUTHOR Jambunathan K"

> 
>     2. The embedded image is stripped from the output. This is a
>        serious bug.

NoRepro - The nifty unicorn image is present in the docx output.

I'm going to tentatively change Status -> NEW and note that the 'AUTHOR' field might be incorrect.
Comment 11 QA Administrators 2015-04-19 03:20:13 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 12 Buovjaga 2015-06-15 10:49:44 UTC
Both the doc and docx export issues are not present anymore.

Ubuntu 15.04 64-bit 
Version: 5.1.0.0.alpha1+
Build ID: a9286c302e96258f32d13fb66aced25750e82cd3
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-06-13_00:35:08
Locale: en-US (en_US.UTF-8)