Bug 46031 - Crash when opening a document from konqueror in a second LibO instance
Summary: Crash when opening a document from konqueror in a second LibO instance
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 02:24 UTC by Nino
Modified: 2012-10-17 06:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
gdb log of soffice process (80.41 KB, text/x-log)
2012-02-14 02:24 UTC, Nino
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nino 2012-02-14 02:24:45 UTC
Created attachment 57026 [details]
gdb log of soffice process

Problem description: I had several crashes when opening a file from konqueror when opening a file in addition to a running LibreOffice instance. 

Not regularly reproducable. From gut feeling I'd tend to blame KDE for the problem, but nevertheless reporting it here.


Steps to reproduce:
1. open a libreoffice instance
2. then, open an odt from konqueror (in my case an ods spreadsheet doc)

Current behavior: crash (sometimes)

Expected behavior: file opens smoothly

Platform:
openSUSE 12.1/KDE
LibreOffice 3.5.0rc3 (parallel installation with "manual" desktop integration)
              
Browser: Mozilla/5.0 (X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 1 Nino 2012-02-14 02:27:20 UTC
changed version to rc3
Comment 2 Nino 2012-02-14 02:31:20 UTC
adjusted summary
Comment 3 Nino 2012-02-14 02:32:09 UTC
adjusted platform
Comment 4 sundoulos2 2012-05-01 16:41:21 UTC
Happens every time for me and has for several versions. Opening an associated file from any sort of link or from dolphin starts a second instance, throws up the document recovery window, then after the file opens the second instance crashes within 30 seconds.

Kubuntu 11.10
LibreOffice 3.5.3 RC2
Sun JRE 1.6.0_23
Comment 5 sasha.libreoffice 2012-05-18 05:25:05 UTC
Thanks for bugreport
Please, create and attach backtrace of crash with symbols
This page may help somehow:
http://wiki.documentfoundation.org/BugReport
Needed installed debugging version of LO (with symbols)
Comment 6 Joel Madero 2012-09-24 20:31:33 UTC
@Sasha - we don't usually ask users to create a backtrace as they are too complicated to create for most people and can create headaches for users and developers alike if not done correctly. This is what our QA team is for

@reporter & sundoulos2: is this still a problem, if it is I'll install konqueror and verify the bug. Then I'll try to get someone to look at it soon - crashes are something we try to tackle quickly once the bug is confirmed.

Thanks for helping us out
Comment 7 sundoulos2 2012-09-25 01:08:33 UTC
(In reply to comment #6)
> @Sasha - we don't usually ask users to create a backtrace as they are too
> complicated to create for most people and can create headaches for users and
> developers alike if not done correctly. This is what our QA team is for
> 
> @reporter & sundoulos2: is this still a problem, if it is I'll install
> konqueror and verify the bug. Then I'll try to get someone to look at it
> soon - crashes are something we try to tackle quickly once the bug is
> confirmed.
> 
> Thanks for helping us out

I can't say for LO 3.5. I'm using Version 3.6.2.1 (Build ID: ba822cc) and it works as expected.
Comment 8 sundoulos2 2012-09-27 00:31:36 UTC
On further testing, here's what I found. I'm using desktop cube, have all my LO stuff on one desktop. If I open a LO file from Dolphin on the desktop where LO is open, it works fine. If I open a file on another desktop, the second instance wants to do a crash recovery, and then crashes itself within 30 seconds of opening the file. Once that happens, opening a LO file from Dolphin is unsuccessful until a reboot - the file opens but spontaneously closes within 30 seconds.
Comment 9 sasha.libreoffice 2012-09-27 05:54:16 UTC
Thanks for additional information.
I still can not reproduce this problem. It LO window with specific document already exist on another desktop and I open the same document with Dolphin, desktop scrolls to desktop where LO window placed.

> Once that happens, opening a LO file from Dolphin is unsuccessful until a reboot > - the file opens but spontaneously closes within 30 seconds.
Looks like problem with video card. It reproducible with video card of another vendor? On another computer or on the same.
Comment 10 sundoulos2 2012-09-27 11:45:14 UTC
(In reply to comment #9)
> Thanks for additional information.
> I still can not reproduce this problem. It LO window with specific document
> already exist on another desktop and I open the same document with Dolphin,
> desktop scrolls to desktop where LO window placed.
I see that behavior on native KDE apps but not LO.
> 
> > Once that happens, opening a LO file from Dolphin is unsuccessful until a reboot > - the file opens but spontaneously closes within 30 seconds.
> Looks like problem with video card. It reproducible with video card of
> another vendor? On another computer or on the same.
I guess that's possible; I'm using an Acer Aspire laptop with Intel 945GM integrated video. I don't have another computer to try it on.
Comment 11 sundoulos2 2012-10-06 02:15:05 UTC
I figured out the problem. It's connected to Workspace Behavior setting for Virtual Desktops. If "Different widgets for each desktop" is selected, LO crashes as described. If it is not selected, LO behaves properly, as described in comment #9.
Comment 12 Joel Madero 2012-10-07 05:52:10 UTC
Then I suspect it's not our bug but now that you've figured out exact cause I'll have someone who uses KDE try it out. Thanks for the further investigation
Comment 13 Robert Großkopf 2012-10-17 06:54:06 UTC
I have tested it with KDE 4.6, OpenSuSE 11.4 32 bit and LO 3.6.3.0+. Changed my desktop to "Different widgets for each desktop". Opened with the mouse one document at one desktop, then changed to another desktop, opened another document. No problem appears.
The described behavior isn't our bug.
I set this bug to Resolved and Notourbug. If somebody thinks it's wrong, he could reopen it.