Download it now!
Bug 46054 - 3.5.0 does not use system's GTK+ style on Linux
Summary: 3.5.0 does not use system's GTK+ style on Linux
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 10:17 UTC by Frank
Modified: 2012-06-21 23:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank 2012-02-14 10:17:59 UTC
After installing 3.5.0 RPMs on Mandriva 2010.2 with KDE 4.5.5, I realised that LibO 3.5.0 does not use the system's GTK+ style, but its own, which is ugly and looks like Win95. This used to work in 3.4.5 (and still does after going back to 3.4.5).
Comment 1 sasha.libreoffice 2012-05-18 05:55:49 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
(3.5.3 or more new)
Comment 2 Frank 2012-06-21 10:26:19 UTC
Thanks for answering!
After having used 3.4 for a while now I retested and found out that the issue is still there in 3.5.3, but after some trying around I found out that it's not a program bug - it's a component I didn't install. Installing gnome-integration (although being on KDE) cured the problem. Did some GTK2-components move from some core package into gnome-integration? In 3.4, things worked nicely on KDE without the gnome-integration package. Maybe one should keep a functioning GTK2 integration even without having to install gnome-integration if GNOME's not used...

Nevertheless, problem solved for me :)
Comment 3 sasha.libreoffice 2012-06-21 23:32:48 UTC
Thanks for additional testing
Due to last comment, changing status to WorksForMe

If problem will appear again, please, change status to Reopened