Bug 46116 - Handling of multiple instances of LO applications in the Unity Launcher
Summary: Handling of multiple instances of LO applications in the Unity Launcher
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) other
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 58657 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-15 08:27 UTC by Anthony Dobaj
Modified: 2012-12-27 14:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
scrsmbled start screen (165.03 KB, image/png)
2012-02-29 22:53 UTC, Ilian Dimitrov
Details
libreoffice launcher issue in unity (489.29 KB, image/png)
2012-12-27 14:55 UTC, pharmankur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Dobaj 2012-02-15 08:27:42 UTC
Ubuntu 11.10 with Unity. Multiple instances of LO applications appear as one icon (that of the initial app) in the launcher. Or, when opening a file from a running app no icon appears in the launcher. Expected behavior is one icon in the launcher for each application (writer, impress, etc).
Comment 1 Ilian Dimitrov 2012-02-29 22:53:38 UTC
Created attachment 57847 [details]
scrsmbled start screen
Comment 2 Ilian Dimitrov 2012-02-29 23:26:48 UTC
It seems that I've found a way to repair this behavior by simply run sudo apt-get install --reinstall libreoffice in terminal. Now Libre Office uses the icons in launcher for it's different apps. I hope it helps you too
Comment 3 Anthony Dobaj 2012-03-01 07:40:41 UTC
Yea, that reinstalls version 3.4, this bug is about version 3.5.
Comment 4 Ilian Dimitrov 2012-03-02 02:22:22 UTC
(In reply to comment #3)
> Yea, that reinstalls version 3.4, this bug is about version 3.5.

No, it actually reinstalled 3.5. I've actually noticed that this helped only for calc, writer still shows different for new text document, but this icon is working, for example when there are more than one text files they're stacked it that icon so you can use them. Still the preinstalled writer icon in launcher only launches documents. The same goes if you use main app libre office, when you choose text document it spawns a  new icon, but like i mentionet before it's usable. anyway I thing that this still is a bug.
Comment 5 Anthony Dobaj 2012-03-05 09:50:01 UTC
Huh, issuing that command line reinstall replaced my 3.5 version with 3.4.4. I tried it again using libreoffice=3.5.0 and apt-get said the version was not found. I tried to "force version" using the synaptic package manager and sure enough 3.4.4 is the only one available. Can you check your package manager and let me know the package location? My original 3.5 installation used dpkg and a downloaded tarball. Maybe this issue is related to installation?
Comment 6 Ilian Dimitrov 2012-03-05 23:40:58 UTC
(In reply to comment #5)
> Huh, issuing that command line reinstall replaced my 3.5 version with 3.4.4. I
> tried it again using libreoffice=3.5.0 and apt-get said the version was not
> found. I tried to "force version" using the synaptic package manager and sure
> enough 3.4.4 is the only one available. Can you check your package manager and
> let me know the package location? My original 3.5 installation used dpkg and a
> downloaded tarball. Maybe this issue is related to installation?

I don't use or have synaptic. My upgrade was done via ppa, so maybe that's the case. After that i run the reinstall. than I have the 3.5 on my system. Why don't you try the ppa method, maybe it'll work.
just in case you're interested:
sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
sudo apt-get dist-upgrade

I've read that It's recommended to first purge the 3.4.4 installation from your system, so maybe you should do that too. Cheers!
Comment 7 Rob Snelders 2012-12-26 09:48:07 UTC
*** Bug 58657 has been marked as a duplicate of this bug. ***
Comment 8 Rob Snelders 2012-12-26 09:50:58 UTC
Is this problem now solved or is it still existing with the latest 3.6-series?

@Ilian: Please keep this bug only over the launcher-app Icons. For the scrambled screen please post another bug.
Comment 9 Rob Snelders 2012-12-26 09:51:59 UTC
Added bjoern as he is the LibreOffice-maintainer for Ubuntu.
Comment 10 Björn Michaelsen 2012-12-26 22:23:31 UTC
How LibreOffice appears in the Unity launcher is not a problem of LibreOffice itself essentially. The bamf and unity packages on Ubuntu are taking care of this. There have been multiple issues on that filed on launchpad, please check if the issue still happens with the latest release (12.10) and otherwise find the bug against bamf on launchpad or file a new one. Thanks.
Comment 11 pharmankur 2012-12-27 14:55:55 UTC
Created attachment 72186 [details]
libreoffice launcher issue in unity

libreoffice launcher issue is still there in ubuntu12.10 

here is my screenshot showing the issue ...