Bug 46135 - FILESAVE: Formulae not saved in Word 2003 (.doc) format
Summary: FILESAVE: Formulae not saved in Word 2003 (.doc) format
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:doc
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2012-02-15 14:03 UTC by dr_tak
Modified: 2017-09-21 22:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Third column was originally sum of first two, formula now gone (10.00 KB, application/msword)
2012-07-15 19:09 UTC, Joel Madero
Details
Third column sum of first two columns, working correctly ODT (9.57 KB, application/vnd.oasis.opendocument.text)
2012-07-15 19:09 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dr_tak 2012-02-15 14:03:03 UTC
Formulae created in tables are saved in .odt format but not in .doc format.
The formulae should not be lost in the conversion.
Comment 1 lauregl 2012-04-19 03:41:36 UTC
[REPRODUCIBLE] with LO 3.5.2 on OSX 10.7.3
Comment 2 sasha.libreoffice 2012-05-21 03:56:56 UTC
reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit
For testing purposes, please, attach correct doc file with formula in table made in msWord.
Comment 3 Joel Madero 2012-07-15 18:57:06 UTC
Attaching documents, confirmed with Version 3.7.0.0.alpha0+ (Build ID: 21f8c28), marking as NEW. 

I am also taking this out of CRITICAL status, this does not constitute a critical bug. Please look at the following chart for an example of how one can categorize bugs. 

https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

This is just one example and other methods of prioritizing can be used but to constitute as a CRITICAL bug, in general we should be seeing some crash, loss of data, etc...

Marking as MINOR -> MEDIUm

Minor because I think it makes it substantially harder to make professional quality work which works smoothly as a .doc. Also marking as MEDIUM priority as it seems like it may affect some users but not most or all. Furthermore, there are workarounds (ie. don't use .doc). 

Can someone test to see if the .odt and/or the .doc formulas are kept in MS Office...

Thanks for reporting
Comment 4 Joel Madero 2012-07-15 19:09:12 UTC
Created attachment 64243 [details]
Third column was originally sum of first two, formula now gone
Comment 5 Joel Madero 2012-07-15 19:09:40 UTC
Created attachment 64244 [details]
Third column sum of first two columns, working correctly ODT
Comment 6 sasha.libreoffice 2012-07-20 11:06:55 UTC
Thanks for attachments. I think we need also correct doc file with working formulas inside (made in msWord). For developers can use it as reference how it should be inside of doc file.
Comment 7 Joel Madero 2012-08-13 22:45:43 UTC
From what I can see I am unable to do a formula inside a table which is inserted into MS Word....am I mistaken? Can someone else try it and attach something here?
Comment 8 Roman Eisele 2012-09-25 08:47:27 UTC
According to comment #2 etc., this bug is not limited to Mac OS X.
According to comment #2 already reproducible in 3.3.4.
-> Adjusted Version and Platform fields.
Comment 9 Alexandr 2014-12-31 11:14:22 UTC
Reproducible with LibreOffice 4.3.3 and 4.4.0 beta2 on Debian.
Comment 10 Xisco Faulí 2015-09-11 12:53:59 UTC
This issue is still present in

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 11 Robinson Tryon (qubit) 2015-12-14 05:59:30 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2017-09-21 22:01:01 UTC
No longer reproduced in

Version: 6.0.0.0.alpha0+
Build ID: 86f256596c8566e80993e1cf6035bc3534b6f816
CPU threads: 4; OS: Linux 4.10; UI render: GL; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME

[Improvement found by office-interoperability-tools]