Download it now!
Bug 46220 - Copy/Paste from Calc to Thunderbird/Postbox lock
Summary: Copy/Paste from Calc to Thunderbird/Postbox lock
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Mac OS X (All)
: high critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.6.0 target:3.5.3
Keywords: regression
: 46247 47880 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-17 02:14 UTC by Vincent Boudry
Modified: 2012-03-26 00:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Boudry 2012-02-17 02:14:05 UTC
Copying a selection of cells from LO3.5.0 to Postbox compose window (I guess it should be the same for Thunderbird) seems to send both program in infinite loop (CPU raises at 100%, no end time until one of the programs is killed).
No such problem with LO 3.4.5.
Comment 1 Vincent Boudry 2012-02-17 05:00:20 UTC
I just noticed that this might be the HTML export that fails.

Copying some cells from Calc and pasting them in a Writer document as HTML (paste special...) results in the same behaviour: 100% CPU...

I haven't seen any problem when pasting in TextEdit (as RTF ?).
Comment 2 Peter Schmitt 2012-03-14 22:47:25 UTC
I can confirm the behaviour in the case that the CELL SELECTION CROSSES OVER HIDDEN COLUMNS:
Copying this selection from CALC and pasting it into Thunderbird leads to hang-up of both LibO and Thunderbird unless CALC becomes terminated by Task-Manager. 
Then Thunderbird will be released.

reproducable on Windows Xp SP3 with LibO 3.5.0 and LOdev3.5.2RC0-nightlyBuild-20120312

it does not happen in LibO 3.4.5
Comment 3 Peter Schmitt 2012-03-15 23:23:25 UTC
Freeze/Hang-Up of both LibO and Thunderbird if Copy&Paste-CELL SELECTION CROSSES OVER HIDDEN COLUMNS also happens in LibO 3.5.1 Release.
Comment 4 Markus Mohrhard 2012-03-22 20:12:47 UTC
I'll take this one.
Comment 5 Not Assigned 2012-03-22 20:39:17 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c4744121f12fde51de2d92d2442d590d93725ffc

increase nCol before next iteratation to prevent loop, fdo#46220
Comment 6 Not Assigned 2012-03-23 07:15:54 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2ccb55183e1131039f062abbbd95caf1451c5efe&g=libreoffice-3-5

increase nCol before next iteratation to prevent loop, fdo#46220


It will be available in LibreOffice 3.5.3.
Comment 7 Markus Mohrhard 2012-03-25 10:08:13 UTC
*** Bug 46247 has been marked as a duplicate of this bug. ***
Comment 8 maxtor 2012-03-26 00:55:06 UTC
*** Bug 47880 has been marked as a duplicate of this bug. ***