Download it now!
Bug 46316 - FILESAVE: Save to PDF produces garbled output, excessive file size
Summary: FILESAVE: Save to PDF produces garbled output, excessive file size
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 22:13 UTC by Elmar
Modified: 2015-03-09 05:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Source document which I attempt to save as PDF (2.84 MB, application/vnd.oasis.opendocument.presentation)
2012-02-19 22:13 UTC, Elmar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar 2012-02-19 22:13:55 UTC
Created attachment 57294 [details]
Source document which I attempt to save as PDF

Version: OOO340m1 (Build:402)

Source document is about 2.8MB. I save to PDF, pages that include normal text are garbled by pictures are fine. PDF file is >22MB.

I save to PPT 2003. Is 3.2MB in size.
Open in MSOffice 2007 (running in VirtualBox). Save to PDF, and is fine. PDF size is 2.4MB.

Have attached the source document. The garbled PDF is too large.
Comment 1 s-joyemusequna 2012-02-20 05:55:41 UTC
Tested with Windows XP and Vista 64 (Libo 3.4.5 and 3.5.0).
No problems, file size < 2,18 MB.
Comment 2 Elmar 2012-02-21 06:23:37 UTC
(In reply to comment #1)
> Tested with Windows XP and Vista 64 (Libo 3.4.5 and 3.5.0).
> No problems, file size < 2,18 MB.

NOTE: The problem is with LO running under Ubuntu 11.04! Not Windows version.

I upgraded from LO 3.4.4. to 3.5 (Ubuntu 11.04) 

Tested again.

The PDF created is now 36MB.
Comment 3 sasha.libreoffice 2012-05-22 07:57:27 UTC
Thanks for bugreport
in 3.5.3 on Fedora 64 bit X-server crashes immediately after attempt to export to PDF. Video is Intel.
Comment 4 sasha.libreoffice 2012-05-22 08:45:15 UTC
On Alt6, 64 bit: in 3.4.3 size of PDF is 18 MB, in 3.5.3 size is 14 MB
Both variants of PDF looks correctly, but shown in OKular very slowly
Impress takes several minutes to generate PDF
Comment 5 A (Andy) 2013-04-25 20:59:48 UTC
not reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

@Elmar & Sasha: Does this issue still persist for in Linux with the latest release of LO?
Comment 6 sasha.libreoffice 2013-04-26 06:38:38 UTC
in 4.0.2 on Fedora (RFR) 64 bit:
size 15.4Mb, exports few minutes, Okular opens slowly (delay in displaying each page)
Comment 7 A (Andy) 2013-04-26 19:40:29 UTC
Then it must be a Linux issue only (see also comment 1).
For me it takes less than 15 seconds and the pdf file size is approx. 2.3 Mb.
Comment 8 QA Administrators 2015-03-04 02:18:00 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 9 Jean-Baptiste Faure 2015-03-09 05:41:13 UTC
Not reproducible with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.
The size of the exported pdf file, depends on the chosen export parameters. It is less than 3.2 MB if I choose compression without loss without reducing the images resolution. The size is 2.C MB if I choose JPEG compression and to reduce image resolution to 300dpi.

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF