Bug 46339 - Query Wizard fails to open
Summary: Query Wizard fails to open
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) Mac OS X (All)
: medium critical
Assignee: Julien Nabet
URL:
Whiteboard: target:3.6.0 target:3.5.1
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-20 05:40 UTC by synfluent
Modified: 2012-04-05 08:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Java stacktrace (2.00 KB, text/plain)
2012-02-20 13:50 UTC, Julien Nabet
Details
Searching the element in double (8.09 KB, text/plain)
2012-02-20 14:30 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description synfluent 2012-02-20 05:40:40 UTC
In Base, the query wizard fails to open when clicked.
All other wizards- form, table, etc- do work.
Problem encountered after upgrading to LibO 3.5.0.

ps: not sure which hardware CPU I have in my MacBook Pro, I know it is an Intel.
Comment 1 Julien Nabet 2012-02-20 13:50:40 UTC
Created attachment 57366 [details]
Java stacktrace

I reproduced this problem from a new odb file on pc Debian 86-64 with 3.5 branch (updated yesterday)
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11pre) (6b24~pre2-1)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

I attached the Java stacktrace. I haven't took a look for the moment, just give these info first.
Comment 2 Julien Nabet 2012-02-20 14:07:44 UTC
Oups, I didn't put the first line, the main info, type of exception : com.sun.star.container.ElementExistException
Comment 3 Julien Nabet 2012-02-20 14:30:18 UTC
Created attachment 57367 [details]
Searching the element in double

I added a System.out.prinln to find which element is in double.
Comment 4 Julien Nabet 2012-02-21 04:48:17 UTC
Keeping on investigation, it seems in the file wizards/com/sun/star/wizards/ui/ControlScroller.java, the line 114 returns empty :
sIncSuffix = com.sun.star.wizards.common.Desktop.getIncrementSuffix(CurUnoDialog.getDlgNameAccess(), "imgBackground");

So line 115 :
CurUnoDialog.insertScrollBar("TitleScrollBar" + sIncSuffix, ....
always uses "TitleScrollBar" as first parameter instead of TitleScrollBar<n>

Must keep on :-)
Comment 5 Julien Nabet 2012-02-21 14:23:37 UTC
By putting some printstacktrace, I just noticed that the constructor ControlScroller is called twice :
- once by AggregateComponent (from QueryWizard.java:209)
- once by TitlesComponent (from QueryWizard.java:342)

Then I don't know if there's something in ControlScroller.java with sIncSuffix (line 114) or the call to CurUnoDialog.insertScrollBar (line 115) or if it's something else. All the files seem have been modified 1 year ago.
Comment 6 Julien Nabet 2012-02-22 14:03:39 UTC
I succeeded to make this work by 2 options :
1) Either
Replace the line 114 :
sIncSuffix = com.sun.star.wizards.common.Desktop.getIncrementSuffix(CurUnoDialog.getDlgNameAccess(), "imgBackground");

by this :
sIncSuffix = com.sun.star.wizards.common.Desktop.getIncrementSuffix(CurUnoDialog.getDlgNameAccess(), "TitleScrollBar");

2) Or
Replace this line 115 :
xScrollBar = CurUnoDialog.insertScrollBar("TitleScrollBar" + sIncSuffix, 0,

by this :
xScrollBar = CurUnoDialog.insertScrollBar("imgBackground" + sIncSuffix, 0,
Comment 7 Julien Nabet 2012-02-22 14:23:19 UTC
(In reply to comment #6)
> I succeeded to make this work by 2 options :
> 1) Either
> Replace the line 114 :
> sIncSuffix =
> com.sun.star.wizards.common.Desktop.getIncrementSuffix(CurUnoDialog.getDlgNameAccess(),
> "imgBackground");
> 
> by this :
> sIncSuffix =
> com.sun.star.wizards.common.Desktop.getIncrementSuffix(CurUnoDialog.getDlgNameAccess(),
> "TitleScrollBar");
> 
> 2) Or
> Replace this line 115 :
> xScrollBar = CurUnoDialog.insertScrollBar("TitleScrollBar" + sIncSuffix, 0,
> 
> by this :
> xScrollBar = CurUnoDialog.insertScrollBar("imgBackground" + sIncSuffix, 0,
Just forgot to precise :
- these lines are in wizards/com/sun/star/wizards/ui/ControlScroller.java
- "TitleScrollBar" is used too line 279 in the same file. Does it indicate something about which option to choose ? (if it's one of them of course :-) )
Comment 8 Caolán McNamara 2012-02-23 07:10:31 UTC
*Presumably* this arises because of the fix
http://cgit.freedesktop.org/libreoffice/core/commit/?id=03e17a141fbb4e1242de9d9979b5b699e6840454
for fdo#42543 ?

Given that the above removed inserting a imgBackground control, my guess would be that your version 1 makes more sense, but I'm just guessing.
Comment 9 Not Assigned 2012-02-23 11:14:01 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bad98a1aa71e1a76c6ca4033f82168fe5b098b64

fdo#46339: Fix Query Wizard by putting the right ElementName
Comment 10 Not Assigned 2012-02-23 12:30:59 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b3a326c16127c9f696e6e4e264729991c4ef4981&g=libreoffice-3-5

fdo#46339: Fix Query Wizard by putting the right ElementName


It will be available in LibreOffice 3.5.2.
Comment 11 Not Assigned 2012-02-24 02:54:47 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=83ba2fb18f3ec7835591c6ffeda6e713bc09a9f9&g=libreoffice-3-5-1

fdo#46339: Fix Query Wizard by putting the right ElementName


It will be available already in LibreOffice 3.5.1.
Comment 12 Rainer Bielefeld Retired 2012-04-05 08:06:31 UTC
I added Fix submitter as assignee because this will ease queries and bub tracking.