Bug 46419 - Uncompleted erase of the pop-up window of a comment inserted in a cell.
Summary: Uncompleted erase of the pop-up window of a comment inserted in a cell.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: easyHack, skillCpp
Depends on:
Blocks:
 
Reported: 2012-02-21 15:09 UTC by Eike Rathke
Modified: 2016-02-18 16:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eike Rathke 2012-02-21 15:09:39 UTC
Originally submitted as https://bugzilla.redhat.com/show_bug.cgi?id=795528 with attached screenshots. Original submitter's description:

Description of problem:
The erase of the pop-up window of a comment inserted in a cell does not delete
all the borders of the window previously opened on the screen.

Version-Release number of selected component (if applicable):
All versions of the LibreOffice-Calc, I suppose.
I have verified the problem in all the following distribution release:
CentOS5, CentOS6, Fedora12 and Fedora14 with OpenOffice, Fedora16 with
LibreOffice.

How reproducible:
Follow the steps below to reproduce the problem.

Steps to Reproduce:
1. Insert a commnet in a cell.
2. Move the cursor of the mouse on the cell to see the inserted comment and
then move the cursor over another cell.
3. The auto closing of the pop-up window leave a line on the screen that is
part of the previous opened window pop-up. 

Actual results:
On the screen remain part of the pop-up comment window.

Expected results:
The complete erase of the pop-up comment window.
Comment 1 Eike Rathke 2012-02-21 15:13:57 UTC
Happens only if the comment box is drawn with its default size, not if resized. Apparently some miscalculation of shadow width/height.
Comment 2 Caolán McNamara 2012-02-22 14:35:27 UTC
When I debugged this I seem to recall that the extra distance came from some anti-aliasing "fill in possible ragged edges code" or something of that nature. I must revisit it to dig out the code in question. My thoughts at the time was that sticking a clipping region in to strictly enforce the bounds that the caption got drawn into might be the easiest fix.
Comment 3 Björn Michaelsen 2013-10-04 18:46:54 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 4 Kevin Suo 2014-05-24 05:47:48 UTC
I do not reproduce this in LibreOffice 4.3 beta1.
I inserted a comment;
clicked another cell;
move to the commented cell, comment show up;
move to another cell, comment hided, with no extra line.

So this may be fixed in 4.3 ?
Comment 5 Jorendc 2014-06-13 08:03:29 UTC
(In reply to comment #4)
> So this may be fixed in 4.3 ?

I think it is. At least, I can not reproduce this bug anymore tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.beta2
Build ID: a06aa316117a6ff0f05c697c82831c227812d810

Marking as RESOLVED WORKSFORME because we don't know which commit fixed this behavior.

Kind regards,
Joren
Comment 6 Robinson Tryon (qubit) 2015-12-16 00:41:03 UTC
Migrating Whiteboard tags to Keywords: (EasyHack SkillCpp)
[NinjaEdit]
Comment 7 Robinson Tryon (qubit) 2016-02-18 16:37:18 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]