Bug Hunting Session
Bug 46452 - Default formatting can not be changed
Summary: Default formatting can not be changed
Status: CLOSED DUPLICATE of bug 46448
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog Number-Format
  Show dependency treegraph
 
Reported: 2012-02-22 06:09 UTC by daniel.schaaaf
Modified: 2017-06-15 17:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.schaaaf 2012-02-22 06:09:17 UTC
Input is interpreted by LibreOffice and Calc chooses a format automatically. If, e.g., the user enters "18.03.12" into a cell, Calc will apply the local date-format to that cell and might change it to "03/18/12".
The default formatting should be customizable by the user. In the given example a user might want Calc to apply a "dd.mm.yyyy" formatting, even though the locale setting is "English (USA)".
This applies to all other possible formats in Calc.

The input recognition itself should also be customizable. If the user, e.g., enters "4/5" into a cell, Calc might interpret the input as a date and change it to "04/05/12". But the user might want Calc to recognize "4/5" as text with only "4/5/12" or "4.5.12" being recognized as a date.
Comment 1 sasha.libreoffice 2012-05-23 04:43:31 UTC
Thanks for new idea
Indeed, currently we have only one option inside of Tools->Options->LibreOffice Calc->Defauls: Number of sheets. 
In another place we can set default language.
So, not implemented yet, changing status to New
Comment 2 Joel Madero 2016-07-04 06:43:14 UTC
Version: 5.3.0.0.alpha0+
Build ID: c89294233b6a9ffc1bd75e6e9226ad723b7d5538
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8)

Still a valid enhancement request.
Comment 3 Eike Rathke 2017-06-15 17:39:59 UTC

*** This bug has been marked as a duplicate of bug 46448 ***