Download it now!
Bug 46485 - EDITING: Inconsistent arrows styles
Summary: EDITING: Inconsistent arrows styles
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Styles
  Show dependency treegraph
 
Reported: 2012-02-22 15:39 UTC by Javi Barroso
Modified: 2017-09-11 11:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Two arrows (one to left and one to right), different styles (27.24 KB, image/png)
2012-02-22 15:39 UTC, Javi Barroso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Javi Barroso 2012-02-22 15:39:03 UTC
Created attachment 57490 [details]
Two arrows (one to left and one to right), different styles

Hi,

Two issues about arrows:

First issue:
1. Create an arrow, it is styled with "Object without Fill"
2. Select Default style and then "Object without Fill" again
Result: Not the same arrow

Second issue:
1. Create an arrow with right direction
2. Create an arrow with left direction
Result: Doesn't have the same style, see image attached where rigth arrow have default style and is "less black" than left arrow (one have default style and the other "Object without Fill" style)

I'm using openoffice 3.5 from Debian Experimental

Thank you very much
Comment 1 sasha.libreoffice 2012-05-23 05:59:55 UTC
Thanks for bugreport.
First problem: reproduced in 3.3.4 and 3.5.3. Style of arrow resets when we change style of arrow. 
IMHO it is a bug, because changing of style resets changes, made manually for object. So should not to be.

Second problem: reproduced in 3.5.3, but not reproduced in 3.3.4, so regression

Experiments made on Fedora 64 bit
Comment 2 retired 2014-11-16 08:52:46 UTC
#1 still happening with Version: 4.4.0.0.alpha2+
Build ID: 30123b9559e2fb74c9db7d530c538a1c6dc7e32c
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2014-11-16_00:07:14

Reproduce:

* Create arrow
* go to Format > Styles and Formatting (top menu)
* it is "Object without fill"
* double click "Object without fill" again

> arror changes
Comment 3 QA Administrators 2015-12-20 16:10:33 UTC Comment hidden (obsolete)
Comment 4 Javi Barroso 2015-12-29 21:59:03 UTC
Still happen,

Different arrow style if you choose a line to right, or you choose a line to left. And an inconsistency on styles in the first case.

Regards,
Comment 5 QA Administrators 2017-09-01 11:16:25 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2017-09-01 11:40:14 UTC
Arrows have been updated recently, please double-check the issue.
Comment 7 Javi Barroso 2017-09-10 22:19:58 UTC
Hello,

The second issue was solved.

The first, please test this:

- Draw a arrow
- Double click on selected style (Object without Fill)
- The arrow changed the style

Thank you !
Comment 8 Heiko Tietze 2017-09-11 11:11:14 UTC
(In reply to Javi Barroso from comment #7)
> Hello,
> 
> The second issue was solved.
> 
> The first, please test this:
> 
> - Draw a arrow
> - Double click on selected style (Object without Fill)
> - The arrow changed the style
> 
> Thank you !

The style 'Object without fill' doesn't include any arrow style (right click the style in the sidebar  > modify or right click the object > Edit Style... and check Arrow Styles under the tab Line. Arrow heads are directly applied likewise many other properties. 

You can modify the style or create another one.