Bug Hunting Session
Bug 46637 - EDITING: Get focus on partially visible cell
Summary: EDITING: Get focus on partially visible cell
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Sahasranaman M S
URL:
Whiteboard: target:5.2.0 target:6.1.0 target:6.0.4
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-26 02:03 UTC by Rainer Bielefeld Retired
Modified: 2018-04-10 20:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots showing unexpected behavior (189.98 KB, application/pdf)
2012-02-26 02:03 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-02-26 02:03:34 UTC
Created attachment 57652 [details]
Screenshots showing unexpected behavior

Steps to reproduce:

1. Start LibO from WIN  start Center
2. Open new CALC document from LibO Start center
3. Arrange a medium size Window for the document so that 1 column at the right 
   is only partially visible (column H in the screeenshot)
4. Mouse Click into H5
   > Cell cursor around H5, focus does not change
5. Start typing some text "This is some Text"
   Expected: Focus should change so that Full cell becomes visible (?)
   Actual: Text will become visible vertically

Currently I am not sure whether my suggestion might collide with other necessities
Comment 1 Rainer Bielefeld Retired 2012-02-26 02:04:52 UTC
There is an AOOo Issue: 118971 - Calc: trying to edit a cell partially off the right edge, should scroll the cell into focus
Comment 2 sasha.libreoffice 2012-05-24 04:11:25 UTC
reproduced in 3.3.4 and 3.5.3 with maximized window also on Fedora 64 bit
looks funny
What is interesting: msExcel 2007 moves sheet in such situations so that all cell appears on screen
Comment 3 Sahasranaman M S 2015-10-30 20:10:01 UTC
Looks like an easy fix.  But would like some comments on how it should behave - should the view scroll to the partially visible cell when it is selected or only when trying to edit it?
Comment 4 Commit Notification 2016-01-11 15:53:53 UTC
Sahasranaman M S committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=08f6107edf3021c31571769e45f7c4b5267d6924

tdf#46637 - Make partially visible cells fully visible on mouse click

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Niklas Johansson 2016-06-29 14:03:13 UTC
Hi

Do you have any time to revisit your patch since it cases the bug tdf#100573 - Display scrolls when opening Auto Filter.

You earlier asked if the scroll should take place only if editing, did you have an idea of how that would be done? That might just fix tdf#100573.

Thanks, for your work on this
Comment 6 Niklas Johansson 2016-07-01 11:32:59 UTC
Also see Bug 100568 - "Display scrolls when opening filter in a pivot table" [1], another bug casued by this fix


[1] https://bugs.documentfoundation.org/show_bug.cgi?id=100568
Comment 7 Sahasranaman M S 2016-07-01 11:59:54 UTC
Hi Niklas,

I'm sorry about these.  I will work on this during the weekend.  If I can't find a solution soon,  this fix can be reverted,  because the problem it solves is not as bad as the problems it is causing.

Thanks,
Sahas
Comment 8 Commit Notification 2016-07-11 15:27:45 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=829dc5ddc53bf0c8e371dd5dd32a7edbf24cdbbf

Resolves: tdf#100573 revert original attempt to resolves tdf#46637

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-07-11 15:27:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=19694ee33b6605e0b881392ad98eeec164ea770c

Related: tdf#100573 try a different approach to solving tdf#46637

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-07-11 18:42:42 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9bf8a970176b16d6bbd00199fd1d9ba6e73b35b5&h=libreoffice-5-2

Resolves: tdf#100573 revert original attempt to resolves tdf#46637

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-07-15 15:41:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e58c1e63f7d0e272065e787bd000b11615e9266b&h=libreoffice-5-2-0

Resolves: tdf#100573 revert original attempt to resolves tdf#46637

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-03-16 09:32:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7619390bd15fa26fc8f74d75f187cf8bf2fca58b

Resolves: tdf#115923 try a different approach to solving tdf#46637

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-03-16 16:01:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d47a28723ee5b8df2f9e34449b15fac7970a1c69&h=libreoffice-6-0

Resolves: tdf#115923 try a different approach to solving tdf#46637

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.