Bug 46670 - WISH: allow pdf files to be embedded in LibO documents
Summary: WISH: allow pdf files to be embedded in LibO documents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-26 23:51 UTC by sergio.callegari
Modified: 2017-12-29 09:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2012-02-26 23:51:18 UTC
Problem description: 

This has wishlist status. LibO includes an extension with lets PDF files be converted (with some minor formatting loss on text) into its native format. This is quite useful for editing PDF files or taking just some parts of a PDF file.  Nonetheless, it would be similarly useful to be able to 'embed' a PDF image 'as is' into a LibO document. In this case, LibO should just take care of just /rendering/ the image at the correct size and resolution. You accept not being able to edit, but you are sure that the formatting is the correct one. I believe that many libraries exist already that could be useful to perform such rendering.

This would be quite useful to those who already have tons of pdf images, since these are the typical format used with pdflatex. Furthermore, I believe that it could greatly simplify extensions such as TexMath, that now need external tools for converting the tex output into something that can be rendered by LibO.

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Comment 1 Roman Eisele 2012-05-07 10:25:43 UTC
This is a feature request, therefore changed Importance to 'enhancement' and Status to 'new'.
Comment 2 sergio.callegari 2017-12-28 09:48:57 UTC
Fixed with new PDF import framework (pdfium)