Bug 46672 - Extension update faces 403 error
Summary: Extension update faces 403 error
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 64383 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-27 00:29 UTC by narayanaras
Modified: 2013-05-10 11:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2012-02-27 00:29:36 UTC
I cannot update THREE extensions, as the update manager reports errors:

Error#1. 
Error reading data from the Internet
Server Error Message: 403 forbidden

http://www.haumacher.de/svg-import/updates does not exist


Error#2. 
Error reading data from the Internet
Server Error Message: 403 forbidden

The host name biblos.no-ip.info could not be resolved

Error#3:
Error while installing extension Palo for OpenOffice. The error message is: Rejecting types due to incompatibility!  [org.palooca.XPalOOCa, members] Different number of types! The extension will not be installed.

I tried to update by two different methods:
1. click on the green arrow icon that appears on the right end of the menu bar. 2. Click on the "Check for Updates" button in the Extension manager. 
But both face the same issues.
Comment 1 Lance Haverkamp 2012-03-08 10:12:59 UTC
Confirmed & changed platform to all.  While I can't actually test "All" it's likely since the same type of behavior is occurring on Linux (Xubuntu 11.10) as well as Windows, as initially reported.
Comment 2 Julien Nabet 2013-05-09 15:10:33 UTC
*** Bug 64383 has been marked as a duplicate of this bug. ***
Comment 3 Julien Nabet 2013-05-09 15:13:37 UTC
It seems you must choose between a new LO version and some extensions.

Could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) update LO and try to install again last versions of these extensions?

FYI: last LO versions are 3.6.6 (for 3.6 branch) and 4.0.2 (for 4.0 branch). 4.0.3 will be released in few days.
Comment 4 narayanaras 2013-05-10 04:49:02 UTC
Hi Julien,

I do have the latest version of (4.0.3.3) LO now (RC 3, which is available as "pre-release" at the LO website.)

The problem existed from 3.5.0. In fact at that time I faced a series of problems, out of which the first two seem to be resolved now.

So given that I am already using the latest LO, and even if I am using an old version of PALO, LO should be able to update it. (Otherwise what's the point of this function?)

I suspect that PALO is really NOT compatible with LibreOffice.
(It is not even listed at http://extensions.libreoffice.org/.)
Comment 5 Julien Nabet 2013-05-10 07:52:25 UTC
narayanaras: thank you for your feedback. So I think you should try to contact author(s) of the extension.
Comment 6 narayanaras 2013-05-10 10:28:37 UTC
Well, if any extension works with OOo, it must work with LO too.

So if the OOo extension does not work with LO, the onus is on LO developers to check why.
Comment 7 Julien Nabet 2013-05-10 11:04:54 UTC
It's not because it works with OOo that it should work with LO.
the code of each one diverge more and more.

Since I may be wrong, I'll let Andras (put in cc) respond.