Download it now!
Bug 46801 - UI: docked slide pane only can show single column (or row) with thumbnails
Summary: UI: docked slide pane only can show single column (or row) with thumbnails
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.1 RC1
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-29 19:12 UTC by kaesezeh
Modified: 2016-05-04 08:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kaesezeh 2012-02-29 19:12:09 UTC
(1a) In the slide sorter, it is still not possible to drag and drop slides around.
(1b) In the slide sorter, slide names are still not displayed.

(2) In the Normal view, one can still only see one column of slides in the slide pane, not 2+ as one could do for years.
Comment 1 Kenneth 2012-03-27 18:13:28 UTC
When I try to move a slide in the slide sorter view, the cursor changes to the circle-with-slash international "no" symbol.
Comment 2 Rainer Bielefeld Retired 2012-07-09 04:22:38 UTC
<http://wiki.documentfoundation.org/BugReport#General_information> item 4!
So I reduce this report to "(1a) In the slide sorter, it is still not possible to drag and drop slides
around.

NOT reproducible with "LibreOffice  3.5.5.3.  German UI/Locale [Build-ID: 7122e39-92ed229-498d286-15e43b4-d70da21] on German WIN7 Home Premium (64bit) 

@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read linked texts

Even if you can not provide all demanded information, every little new information might bring the breakthrough.

Please submit Bug reports with status UNCONFIRMED!
Comment 3 kaesezeh 2012-07-13 16:05:36 UTC
Additional comments:

> (1a) In the slide sorter, it is still not possible to drag and drop slides
around.
This is fixed in 3.5.4.2.

> (1b) In the slide sorter, slide names are still not displayed.
Slide names are still only shown on mouse-over rather than, as some time ago, always (before LO 3.3 I think), which does not help when it comes to keeping track of many slides.

> (2) In the Normal view, one can still only see one column of slides in the
slide pane, not 2+ as one could do for years.
This is still not fixed. Previously, one could re-size the slide pane to see slides like this

1  2
3  4
5  6
...

or

1  2  3
4  5  6
...

Now, one can only see one column of slides in different sizes, which again doesn't help with more complex presentations.
Comment 4 Rainer Bielefeld Retired 2012-07-27 04:41:40 UTC
For "1b" we already have "Bug 37654 - UI Slide names no longer visible in Slide Pane / Page Pane"

"2" only affects docked slide pane, in floating pane you can see multiple columns with thumbnails. 

That still worked in LibO 3.1.1 and with "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit) 

[Reproducible] with "LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit) 

[Reproducible] with "LibreOffice 3.4.1RC1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:101)]" 

So it seems we lost that with 3.4

A docked horizontal slides pane only can show a single row of thumbnails

All the same in DRAW.

@Ivan:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 5 Ivan Timofeev (retired) 2012-07-28 10:48:19 UTC
(In reply to comment #4)
> A docked horizontal slides pane only can show a single row of thumbnails

That is intentional, and looks like it comes from this commit:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=b390fae1706b9c511158a03e4fd61f263be4e511

I am neither a designer nor a Draw/Impress-guy, so I won't touch it; after all if you want to see more slides, there is the slide sorter. :-/
Comment 6 Heiko Tietze 2016-05-04 08:31:19 UTC
Following Rainer's considerations I'm closing this bug as WORKSFORME (actually it was fixed).

Sorting pages works like a charm, labels are discussed in a different bug report plus there is the navigator that shows it nicely.